aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarco Huenseler <marcoh.huenseler+git@gmail.com>2017-06-25 14:29:43 +0200
committerMarco Huenseler <marcoh.huenseler+git@gmail.com>2017-06-25 14:29:43 +0200
commitcc32d985f5b9f9051026d0834eab4c1508365917 (patch)
treefd8c6bf94995507f1d2422cfc05decb4e3fc7651 /setup.py
downloadradicale_auth_ldap-cc32d985f5b9f9051026d0834eab4c1508365917.tar.gz
radicale_auth_ldap-cc32d985f5b9f9051026d0834eab4c1508365917.tar.bz2
radicale_auth_ldap-cc32d985f5b9f9051026d0834eab4c1508365917.zip
initial commit, just some small syntax sugar for Raoul Thill's LDAP plugin
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 12 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..b10822a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,12 @@
+#!/usr/bin/env python3
+
+from setuptools import setup
+
+setup(
+ name="radicale-auth-ldap",
+ version="0.1",
+ description="LDAP Authentication Plugin for Radicale 2",
+ author="Raoul Thill",
+ license="GNU GPL v3",
+ install_requires=["radicale>=2.0", "ldap3"],
+ packages=["radicale_auth_ldap"])
bgstack15