summaryrefslogtreecommitdiff
path: root/yt-dlp/debian/patches/0005-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'yt-dlp/debian/patches/0005-Makefile-Don-t-run-flake8-when-running-offlinetest.patch')
-rw-r--r--yt-dlp/debian/patches/0005-Makefile-Don-t-run-flake8-when-running-offlinetest.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/yt-dlp/debian/patches/0005-Makefile-Don-t-run-flake8-when-running-offlinetest.patch b/yt-dlp/debian/patches/0005-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
new file mode 100644
index 0000000..07fbc02
--- /dev/null
+++ b/yt-dlp/debian/patches/0005-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
@@ -0,0 +1,25 @@
+From: =?utf-8?q?Rog=C3=A9rio_Brito?= <rbrito@gmail.com>
+Date: Sun, 22 Nov 2020 20:06:55 -0300
+Subject: Makefile: Don't run flake8 when running offlinetest.
+
+Unfortunately, due to the dynamic nature of python, we most certainly would
+like to run flake8 when testing the package. Alas, flake8 sometimes
+generates style-only warning or "errors" that break the build, in a similar
+fashion to what -Werror does to GCC or other compilers.
+
+Therefore, I'm disabling this.
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Makefile 2021-12-01 15:12:36.202897749 -0500
++++ b/Makefile 2021-12-01 15:12:36.190897872 -0500
+@@ -58,7 +58,7 @@
+ $(PYTHON) -m pytest
+ $(MAKE) codetest
+
+-offlinetest: codetest
++offlinetest:
+ $(PYTHON) -m pytest -k "not download"
+
+ yt-dlp: yt_dlp/*.py yt_dlp/*/*.py
bgstack15