summaryrefslogtreecommitdiff
path: root/xpipe/debian/patches/01-makefile-option-bsddir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'xpipe/debian/patches/01-makefile-option-bsddir.patch')
-rw-r--r--xpipe/debian/patches/01-makefile-option-bsddir.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/xpipe/debian/patches/01-makefile-option-bsddir.patch b/xpipe/debian/patches/01-makefile-option-bsddir.patch
new file mode 100644
index 0000000..fbfe845
--- /dev/null
+++ b/xpipe/debian/patches/01-makefile-option-bsddir.patch
@@ -0,0 +1,28 @@
+Description: Add Makefile option for BSDDIR
+ Debian does not store libbsd headers directly at /usr/include/bsd; it
+ stores them elsewhere.
+ .
+ Use this patch to find it or else be able to set it on the Make
+ invocation with `make BSDDIR=/path/to/libbsd/include/bsd`
+Author: B. Stack <bgstack15@gmail.com>
+Origin: Devuan
+Last-Update: 2024-03-20
+--- a/Makefile
++++ b/Makefile
+@@ -6,6 +6,7 @@ PREFIX?=/usr/local
+ CFLAGS+= -Wall -Werror -Wextra -I${PREFIX}/include
+ LDFLAGS+= -L${PREFIX}/lib
+ LIBS= -lm
++BSDDIR :=$(shell find /usr/include -name bsd -type d -quit)
+
+ OS!=uname
+
+@@ -28,7 +29,7 @@ help:
+ configure:
+ @ \
+ if [ "x${OS}" = x"Linux" ]; then \
+- if [ ! -d /usr/include/bsd ] && [ ! -d ${PREFIX}/include/bsd ]; then \
++ if [ ! -d /usr/include/bsd ] && [ ! -d ${PREFIX}/include/bsd ] && [ ! -d ${BSDDIR} ] ; then \
+ echo "Please install 'libbsd' and 'libbsd-devel'." >&2; \
+ exit 1; \
+ fi; \
bgstack15