summaryrefslogtreecommitdiff
path: root/veracrypt/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'veracrypt/debian/patches')
-rw-r--r--veracrypt/debian/patches/1001-port-to-libfuse3.patch33
-rw-r--r--veracrypt/debian/patches/1002-fix-ftbfs-32bit.patch33
-rw-r--r--veracrypt/debian/patches/series1
-rw-r--r--veracrypt/debian/patches/vc_devuan.patch11
4 files changed, 17 insertions, 61 deletions
diff --git a/veracrypt/debian/patches/1001-port-to-libfuse3.patch b/veracrypt/debian/patches/1001-port-to-libfuse3.patch
index 5f2860e..d0b9565 100644
--- a/veracrypt/debian/patches/1001-port-to-libfuse3.patch
+++ b/veracrypt/debian/patches/1001-port-to-libfuse3.patch
@@ -3,32 +3,21 @@ From: Unit 193 <unit193@unit193.net>
Forwarded: https://github.com/veracrypt/VeraCrypt/issues/528
---
- src/Driver/Fuse/Driver.make | 2 +-
src/Driver/Fuse/FuseService.cpp | 26 +++++++++-----------------
- src/Main/Main.make | 2 +-
- 3 files changed, 11 insertions(+), 19 deletions(-)
+ src/Makefile | 2 +-
+ 2 files changed, 10 insertions(+), 18 deletions(-)
---- a/src/Main/Main.make
-+++ b/src/Main/Main.make
-@@ -102,7 +102,7 @@ endif
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -52,7 +52,7 @@ export LFLAGS :=
- #------ FUSE configuration ------
+ export PKG_CONFIG ?= pkg-config
+ export PKG_CONFIG_PATH ?= /usr/local/lib/pkgconfig
+-export VC_FUSE_PACKAGE := fuse
++export VC_FUSE_PACKAGE := fuse3
+ export VC_OSX_FUSET ?= 0
--FUSE_LIBS = $(shell $(PKG_CONFIG) fuse --libs)
-+FUSE_LIBS = $(shell $(PKG_CONFIG) fuse3 --libs)
-
- #------ Executable ------
-
---- a/src/Driver/Fuse/Driver.make
-+++ b/src/Driver/Fuse/Driver.make
-@@ -15,6 +15,6 @@ NAME := Driver
- OBJS :=
- OBJS += FuseService.o
-
--CXXFLAGS += $(shell $(PKG_CONFIG) fuse --cflags)
-+CXXFLAGS += $(shell $(PKG_CONFIG) fuse3 --cflags)
-
- include $(BUILD_INC)/Makefile.inc
+ export WX_CONFIG ?= wx-config
--- a/src/Driver/Fuse/FuseService.cpp
+++ b/src/Driver/Fuse/FuseService.cpp
@@ -13,7 +13,7 @@
diff --git a/veracrypt/debian/patches/1002-fix-ftbfs-32bit.patch b/veracrypt/debian/patches/1002-fix-ftbfs-32bit.patch
deleted file mode 100644
index 9cd566f..0000000
--- a/veracrypt/debian/patches/1002-fix-ftbfs-32bit.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From bd843ffa05147aab80e38ee668b0556302d2bfc9 Mon Sep 17 00:00:00 2001
-From: Mounir IDRASSI <mounir.idrassi@idrix.fr>
-Date: Mon, 2 Oct 2023 18:02:33 +0200
-Subject: [PATCH] Linux: Fix compilation error on some 32-bit machines.
-
----
- src/Common/PCSCException.cpp | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/src/Common/PCSCException.cpp b/src/Common/PCSCException.cpp
-index 93fff18187..dc5eead323 100644
---- a/src/Common/PCSCException.cpp
-+++ b/src/Common/PCSCException.cpp
-@@ -140,14 +140,17 @@ namespace VeraCrypt
- {
- Exception::Deserialize(stream);
- Serializer sr(stream);
-- sr.Deserialize("ErrorCode", ErrorCode);
-+ int64 v;
-+ sr.Deserialize("ErrorCode", v);
-+ ErrorCode = (LONG_PCSC)v;
- }
-
- void PCSCException::Serialize(shared_ptr <Stream> stream) const
- {
- Exception::Serialize(stream);
- Serializer sr(stream);
-- sr.Serialize("ErrorCode", ErrorCode);
-+ int64 v = (int64)ErrorCode;
-+ sr.Serialize("ErrorCode", v);
- }
-
- # define TC_EXCEPTION(TYPE) TC_SERIALIZER_FACTORY_ADD(TYPE)
diff --git a/veracrypt/debian/patches/series b/veracrypt/debian/patches/series
index 831301f..8518785 100644
--- a/veracrypt/debian/patches/series
+++ b/veracrypt/debian/patches/series
@@ -1,3 +1,2 @@
1001-port-to-libfuse3.patch
-1002-fix-ftbfs-32bit.patch
vc_devuan.patch
diff --git a/veracrypt/debian/patches/vc_devuan.patch b/veracrypt/debian/patches/vc_devuan.patch
index 386e777..b55dbaf 100644
--- a/veracrypt/debian/patches/vc_devuan.patch
+++ b/veracrypt/debian/patches/vc_devuan.patch
@@ -1,10 +1,11 @@
-Version: 1.26.7
-Date: 2023-10-03
+Version: 1.26.14
+Date: 2024-09-03
+Message: Change distributor name
--- a/src/Common/Dlgcode.c
+++ b/src/Common/Dlgcode.c
@@ -2171,7 +2171,7 @@ BOOL CALLBACK AboutDlgProc (HWND hwndDlg
L"This software as a whole:\r\n"
- L"Copyright \xA9 2013-2023 IDRIX. All rights reserved.\r\n\r\n"
+ L"Copyright \xA9 2013-2024 IDRIX. All rights reserved.\r\n\r\n"
- L"An IDRIX Release");
+ L"Packaged for Devuan");
@@ -13,7 +14,7 @@ Date: 2023-10-03
--- a/src/Common/Tcdefs.h
+++ b/src/Common/Tcdefs.h
-@@ -447,7 +447,7 @@ void EraseMemory (void *memory, int size
+@@ -451,7 +451,7 @@ void EraseMemory (void *memory, int size
#define TC_MAX_PATH 260 /* Includes the null terminator */
#endif
@@ -24,7 +25,7 @@ Date: 2023-10-03
--- a/src/Main/Forms/AboutDialog.cpp
+++ b/src/Main/Forms/AboutDialog.cpp
-@@ -74,6 +74,6 @@ namespace VeraCrypt
+@@ -78,6 +78,6 @@ namespace VeraCrypt
L"This software uses wxWidgets library, which is copyright \xA9 1998-2011 Julian Smart, Robert Roebling et al.\n\n"
bgstack15