summaryrefslogtreecommitdiff
path: root/spacecadetpinball/debian
diff options
context:
space:
mode:
Diffstat (limited to 'spacecadetpinball/debian')
-rw-r--r--spacecadetpinball/debian/README.Debian5
-rwxr-xr-xspacecadetpinball/debian/SpaceCadetPinball17
-rw-r--r--spacecadetpinball/debian/SpaceCadetPinball.123
-rw-r--r--spacecadetpinball/debian/changelog5
-rw-r--r--spacecadetpinball/debian/control19
-rw-r--r--spacecadetpinball/debian/copyright284
-rw-r--r--spacecadetpinball/debian/patches/series1
-rwxr-xr-xspacecadetpinball/debian/rules20
-rw-r--r--spacecadetpinball/debian/source/format1
-rw-r--r--spacecadetpinball/debian/source/include-binaries51
-rw-r--r--spacecadetpinball/debian/source/lintian-overrides1
-rw-r--r--spacecadetpinball/debian/spacecadetpinball+stackrpms.dsc14
-rw-r--r--spacecadetpinball/debian/spacecadetpinball.desktop9
-rw-r--r--spacecadetpinball/debian/spacecadetpinball.install2
-rw-r--r--spacecadetpinball/debian/spacecadetpinball.lintian-overrides1
-rw-r--r--spacecadetpinball/debian/spacecadetpinball.manpages1
-rw-r--r--spacecadetpinball/debian/upstream/metadata16
-rw-r--r--spacecadetpinball/debian/watch2
18 files changed, 472 insertions, 0 deletions
diff --git a/spacecadetpinball/debian/README.Debian b/spacecadetpinball/debian/README.Debian
new file mode 100644
index 0000000..01c8ae3
--- /dev/null
+++ b/spacecadetpinball/debian/README.Debian
@@ -0,0 +1,5 @@
+spacecadetpinball for Devuan
+
+This is the full version of the game.
+
+ -- B. Stack <bgstack15@gmail.com> Thu, 31 Oct 2024 22:23:42 -0400
diff --git a/spacecadetpinball/debian/SpaceCadetPinball b/spacecadetpinball/debian/SpaceCadetPinball
new file mode 100755
index 0000000..033de43
--- /dev/null
+++ b/spacecadetpinball/debian/SpaceCadetPinball
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+# Configure soundfonts if not already configured
+if [ -z "$SDL_SOUNDFONTS" ]; then
+ DEFAULT_SOUNDFONT="/usr/share/soundfonts/default.sf2"
+ if [ -f "$DEFAULT_SOUNDFONT" ]; then
+ # Use default soundfont since it exists
+ export SDL_SOUNDFONTS="$DEFAULT_SOUNDFONT"
+ else
+ # Use first available soundfont
+ export SDL_SOUNDFONTS="$(find /usr/share/soundfonts -type f,l -print -quit 2> /dev/null)"
+ fi
+fi
+
+# Run program in correct directory so it can find it's resources
+cd /usr/lib/spacecadetpinball
+exec ./SpaceCadetPinball "$@"
diff --git a/spacecadetpinball/debian/SpaceCadetPinball.1 b/spacecadetpinball/debian/SpaceCadetPinball.1
new file mode 100644
index 0000000..36c6a41
--- /dev/null
+++ b/spacecadetpinball/debian/SpaceCadetPinball.1
@@ -0,0 +1,23 @@
+.\" Text automatically generated by txt2man-wrapper
+.TH SpaceCadetPinball 6 "November 2024" "spacecadetpinball" "Games"
+.SH NAME
+\fBSpaceCadetPinball \fP- 3d \fBPinball\fP \fBfor\fP \fBWindows\fP
+.SH SYNOPSIS
+.nf
+.fam C
+\fBSpaceCadetPinball\fP
+.fam T
+.fi
+.fam T
+.fi
+.SH OPTIONS
+none
+.SH DESCRIPTION
+This is a reverse-engineered engine \fBfor\fP `\fB3D\fP \fBPinball\fP \fBfor\fP \fBWindows\fP - \fBSpace\fP \fBCadet\fP`.
+The wrapper in /usr/games sets some minor environment variables before running the game.
+.SH AUTHOR
+k4zmu2a
+.SH COPYRIGHT
+MIT License
+.SH BUGS
+See <https://github.com/k4zmu2a/\fBSpaceCadetPinball\fP>
diff --git a/spacecadetpinball/debian/changelog b/spacecadetpinball/debian/changelog
new file mode 100644
index 0000000..66e3a9b
--- /dev/null
+++ b/spacecadetpinball/debian/changelog
@@ -0,0 +1,5 @@
+spacecadetpinball (2.1.0-1+stackrpms) obs; urgency=low
+
+ * Initial release. Closes: packages-want#36
+
+ -- B. Stack <bgstack15@gmail.com> Thu, 31 Oct 2024 22:23:42 -0400
diff --git a/spacecadetpinball/debian/control b/spacecadetpinball/debian/control
new file mode 100644
index 0000000..b44a34d
--- /dev/null
+++ b/spacecadetpinball/debian/control
@@ -0,0 +1,19 @@
+Source: spacecadetpinball
+Section: games
+Priority: optional
+Maintainer: B. Stack <bgstack15@gmail.com>
+Build-Depends: debhelper-compat (= 13),
+ cmake,
+ libsdl2-dev,
+ libsdl2-mixer-dev,
+Standards-Version: 4.6.1
+Homepage: https://github.com/k4zmu2a/SpaceCadetPinball
+Rules-Requires-Root: no
+
+Package: spacecadetpinball
+Architecture: any
+Multi-Arch: foreign
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Description: 3D Pinball - Space Cadet
+ A reverse-engineered engine using some of the original
+ Windows-based game.
diff --git a/spacecadetpinball/debian/copyright b/spacecadetpinball/debian/copyright
new file mode 100644
index 0000000..e68d879
--- /dev/null
+++ b/spacecadetpinball/debian/copyright
@@ -0,0 +1,284 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: spacecadetpinball
+Upstream-Contact: k4zmu2a
+Source: https://github.com/k4zmu2a/SpaceCadetPinball
+
+Files: .gitattributes
+ .github/workflows/ReleaseBuilds.yml
+ .gitignore
+ BuildForWindows.ps1
+ CMakeLists.txt
+ CMakeSettings.json
+ CONTRIBUTING.md
+ Doc/.dat dump.txt
+ Doc/.dat file format.txt
+ Doc/.pdb dump.txt
+ Doc/FuncStats.xlsx
+ Platform/Linux/BUILD.md
+ Platform/Linux/SpaceCadetPinball.desktop
+ Screenshots/screenshot-1.jpg
+ Screenshots/screenshot-2.jpg
+ SpaceCadetPinball/DebugOverlay.cpp
+ SpaceCadetPinball/DebugOverlay.h
+ SpaceCadetPinball/EmbeddedData.cpp
+ SpaceCadetPinball/EmbeddedData.h
+ SpaceCadetPinball/GroupData.cpp
+ SpaceCadetPinball/GroupData.h
+ SpaceCadetPinball/Icon_1.ico
+ SpaceCadetPinball/Icon_128x128.png
+ SpaceCadetPinball/Icon_16x16.png
+ SpaceCadetPinball/Icon_192x192.png
+ SpaceCadetPinball/Icon_32x32.png
+ SpaceCadetPinball/Icon_48x48.png
+ SpaceCadetPinball/PB_MSGFT.bin
+ SpaceCadetPinball/Sound.cpp
+ SpaceCadetPinball/Sound.h
+ SpaceCadetPinball/SpaceCadetPinball.cpp
+ SpaceCadetPinball/SpaceCadetPinball.rc
+ SpaceCadetPinball/TBall.cpp
+ SpaceCadetPinball/TBall.h
+ SpaceCadetPinball/TBlocker.cpp
+ SpaceCadetPinball/TBlocker.h
+ SpaceCadetPinball/TBumper.cpp
+ SpaceCadetPinball/TBumper.h
+ SpaceCadetPinball/TCircle.cpp
+ SpaceCadetPinball/TCircle.h
+ SpaceCadetPinball/TCollisionComponent.cpp
+ SpaceCadetPinball/TCollisionComponent.h
+ SpaceCadetPinball/TComponentGroup.cpp
+ SpaceCadetPinball/TComponentGroup.h
+ SpaceCadetPinball/TDemo.cpp
+ SpaceCadetPinball/TDemo.h
+ SpaceCadetPinball/TDrain.cpp
+ SpaceCadetPinball/TDrain.h
+ SpaceCadetPinball/TEdgeBox.h
+ SpaceCadetPinball/TEdgeManager.cpp
+ SpaceCadetPinball/TEdgeManager.h
+ SpaceCadetPinball/TEdgeSegment.cpp
+ SpaceCadetPinball/TEdgeSegment.h
+ SpaceCadetPinball/TFlagSpinner.cpp
+ SpaceCadetPinball/TFlagSpinner.h
+ SpaceCadetPinball/TFlipper.cpp
+ SpaceCadetPinball/TFlipper.h
+ SpaceCadetPinball/TFlipperEdge.cpp
+ SpaceCadetPinball/TFlipperEdge.h
+ SpaceCadetPinball/TGate.cpp
+ SpaceCadetPinball/TGate.h
+ SpaceCadetPinball/THole.cpp
+ SpaceCadetPinball/THole.h
+ SpaceCadetPinball/TKickback.cpp
+ SpaceCadetPinball/TKickback.h
+ SpaceCadetPinball/TKickout.cpp
+ SpaceCadetPinball/TKickout.h
+ SpaceCadetPinball/TLight.cpp
+ SpaceCadetPinball/TLight.h
+ SpaceCadetPinball/TLightBargraph.cpp
+ SpaceCadetPinball/TLightBargraph.h
+ SpaceCadetPinball/TLightGroup.cpp
+ SpaceCadetPinball/TLightGroup.h
+ SpaceCadetPinball/TLightRollover.cpp
+ SpaceCadetPinball/TLightRollover.h
+ SpaceCadetPinball/TLine.cpp
+ SpaceCadetPinball/TLine.h
+ SpaceCadetPinball/TOneway.cpp
+ SpaceCadetPinball/TOneway.h
+ SpaceCadetPinball/TPinballComponent.cpp
+ SpaceCadetPinball/TPinballComponent.h
+ SpaceCadetPinball/TPinballTable.cpp
+ SpaceCadetPinball/TPinballTable.h
+ SpaceCadetPinball/TPlunger.cpp
+ SpaceCadetPinball/TPlunger.h
+ SpaceCadetPinball/TPopupTarget.cpp
+ SpaceCadetPinball/TPopupTarget.h
+ SpaceCadetPinball/TRamp.cpp
+ SpaceCadetPinball/TRamp.h
+ SpaceCadetPinball/TRollover.cpp
+ SpaceCadetPinball/TRollover.h
+ SpaceCadetPinball/TSink.cpp
+ SpaceCadetPinball/TSink.h
+ SpaceCadetPinball/TSoloTarget.cpp
+ SpaceCadetPinball/TSoloTarget.h
+ SpaceCadetPinball/TSound.cpp
+ SpaceCadetPinball/TSound.h
+ SpaceCadetPinball/TTableLayer.cpp
+ SpaceCadetPinball/TTableLayer.h
+ SpaceCadetPinball/TTextBox.cpp
+ SpaceCadetPinball/TTextBox.h
+ SpaceCadetPinball/TTextBoxMessage.cpp
+ SpaceCadetPinball/TTextBoxMessage.h
+ SpaceCadetPinball/TTimer.cpp
+ SpaceCadetPinball/TTimer.h
+ SpaceCadetPinball/TTripwire.cpp
+ SpaceCadetPinball/TTripwire.h
+ SpaceCadetPinball/TWall.cpp
+ SpaceCadetPinball/TWall.h
+ SpaceCadetPinball/control.cpp
+ SpaceCadetPinball/control.h
+ SpaceCadetPinball/font_selection.cpp
+ SpaceCadetPinball/font_selection.h
+ SpaceCadetPinball/fullscrn.cpp
+ SpaceCadetPinball/fullscrn.h
+ SpaceCadetPinball/gdrv.cpp
+ SpaceCadetPinball/gdrv.h
+ SpaceCadetPinball/high_score.cpp
+ SpaceCadetPinball/high_score.h
+ SpaceCadetPinball/imconfig.h
+ SpaceCadetPinball/imgui.cpp
+ SpaceCadetPinball/imgui.h
+ SpaceCadetPinball/imgui_demo.cpp
+ SpaceCadetPinball/imgui_impl_sdl.cpp
+ SpaceCadetPinball/imgui_impl_sdl.h
+ SpaceCadetPinball/imgui_impl_sdlrenderer.cpp
+ SpaceCadetPinball/imgui_impl_sdlrenderer.h
+ SpaceCadetPinball/imgui_internal.h
+ SpaceCadetPinball/imgui_sdl.cpp
+ SpaceCadetPinball/imgui_sdl.h
+ SpaceCadetPinball/imgui_tables.cpp
+ SpaceCadetPinball/imgui_widgets.cpp
+ SpaceCadetPinball/loader.cpp
+ SpaceCadetPinball/loader.h
+ SpaceCadetPinball/maths.cpp
+ SpaceCadetPinball/maths.h
+ SpaceCadetPinball/midi.cpp
+ SpaceCadetPinball/midi.h
+ SpaceCadetPinball/nudge.cpp
+ SpaceCadetPinball/nudge.h
+ SpaceCadetPinball/options.cpp
+ SpaceCadetPinball/options.h
+ SpaceCadetPinball/partman.cpp
+ SpaceCadetPinball/partman.h
+ SpaceCadetPinball/pb.cpp
+ SpaceCadetPinball/pb.h
+ SpaceCadetPinball/pch.h
+ SpaceCadetPinball/proj.cpp
+ SpaceCadetPinball/proj.h
+ SpaceCadetPinball/render.cpp
+ SpaceCadetPinball/render.h
+ SpaceCadetPinball/score.cpp
+ SpaceCadetPinball/score.h
+ SpaceCadetPinball/splash_bitmap.bmp
+ SpaceCadetPinball/timer.cpp
+ SpaceCadetPinball/timer.h
+ SpaceCadetPinball/translations.cpp
+ SpaceCadetPinball/translations.h
+ SpaceCadetPinball/winmain.cpp
+ SpaceCadetPinball/winmain.h
+ SpaceCadetPinball/zdrv.cpp
+ SpaceCadetPinball/zdrv.h
+ build-mac-app.sh
+ mingwcc.cmake
+Copyright: __NO_COPYRIGHT_NOR_LICENSE__
+License: __NO_COPYRIGHT_NOR_LICENSE__
+
+Files: SpaceCadetPinball/imstb_rectpack.h
+ SpaceCadetPinball/imstb_textedit.h
+Copyright: 2017 Sean Barrett
+License: Expat
+ Permission is hereby granted, free of charge, to any person obtaining a copy of
+ this software and associated documentation files (the "Software"), to deal in
+ the Software without restriction, including without limitation the rights to
+ use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+ of the Software, and to permit persons to whom the Software is furnished to do
+ so, subject to the following conditions:
+ The above copyright notice and this permission notice shall be included in all
+ copies or substantial portions of the Software.
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
+
+Files: CMakeModules/FindSDL2.cmake
+ CMakeModules/FindSDL2_mixer.cmake
+Copyright: 2003-2009 Kitware, Inc.
+ 2012 Benjamin Eikel
+License: __UNKNOWN__
+ Distributed under the OSI-approved BSD License (the "License");
+ see accompanying file Copyright.txt for details.
+ .
+ This software is distributed WITHOUT ANY WARRANTY; without even the
+ implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+ See the License for more information.
+
+Files: SpaceCadetPinball/imstb_truetype.h
+Copyright: 2017 Sean Barrett
+License: __UNKNOWN__
+ Permission is hereby granted, free of charge, to any person obtaining a copy of
+ __MANY_TOTAL_LINES__(5051lines) truncating at: this software and associated documentation files (the "Software"
+ this software and associated documentation files (the "Software"), to deal in
+ __MANY_TOTAL_LINES__(5052lines) truncating at: the Software without restriction, including without limitation t
+ the Software without restriction, including without limitation the rights to
+ __MANY_TOTAL_LINES__(5053lines) truncating at: use, copy, modify, merge, publish, distribute, sublicense, and/o
+ use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+ __MANY_TOTAL_LINES__(5054lines) truncating at: of the Software, and to permit persons to whom the Software is f
+ of the Software, and to permit persons to whom the Software is furnished to do
+ __MANY_TOTAL_LINES__(5055lines) truncating at: so, subject to the following conditions:
+ so, subject to the following conditions:
+ __MANY_TOTAL_LINES__(5056lines) truncating at: The above copyright notice and this permission notice shall be i
+ The above copyright notice and this permission notice shall be included in all
+ __MANY_TOTAL_LINES__(5057lines) truncating at: copies or substantial portions of the Software.
+ copies or substantial portions of the Software.
+ __MANY_TOTAL_LINES__(5058lines) truncating at: THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ __MANY_TOTAL_LINES__(5059lines) truncating at: IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANT
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ __MANY_TOTAL_LINES__(5060lines) truncating at: FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVEN
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ __MANY_TOTAL_LINES__(5061lines) truncating at: AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ __MANY_TOTAL_LINES__(5062lines) truncating at: LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ __MANY_TOTAL_LINES__(5063lines) truncating at: OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DE
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ __MANY_TOTAL_LINES__(5064lines) truncating at: SOFTWARE.
+ SOFTWARE.
+ __MANY_TOTAL_LINES__(5065lines) truncating at: ----------------------------------------------------------------
+
+Files: SpaceCadetPinball/imgui_draw.cpp
+Copyright: 2004-2005 Tristan Grimmer
+License: __UNKNOWN__
+ MIT license (see License.txt in http://www.upperbounds.net/download/ProggyClean.ttf.zip)
+ __MANY_TOTAL_LINES__(4070lines) truncating at: // Download and more information at http://upperbounds.net
+ Download and more information at http://upperbounds.net
+ __MANY_TOTAL_LINES__(4071lines) truncating at: //--------------------------------------------------------------
+
+#----------------------------------------------------------------------------
+# xml and html files (skipped):
+# README.md
+# Platform/Linux/SpaceCadetPinball.metainfo.xml
+# Platform/macOS/Info.plist
+# SpaceCadetPinball/NatvisFile.natvis
+
+#----------------------------------------------------------------------------
+# huge files (skipped):
+# Platform/macOS/SpaceCadetPinball.icns
+
+#----------------------------------------------------------------------------
+# Files marked as NO_LICENSE_TEXT_FOUND may be covered by the following
+# license/copyright files.
+
+#----------------------------------------------------------------------------
+# License file: LICENSE
+ MIT License
+ .
+ Copyright (c) 2020-2021 Andrey Muzychenko
+ .
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in all
+ copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
diff --git a/spacecadetpinball/debian/patches/series b/spacecadetpinball/debian/patches/series
new file mode 100644
index 0000000..4a97dfa
--- /dev/null
+++ b/spacecadetpinball/debian/patches/series
@@ -0,0 +1 @@
+# You must remove unused comment lines for the released package.
diff --git a/spacecadetpinball/debian/rules b/spacecadetpinball/debian/rules
new file mode 100755
index 0000000..e9a9fb3
--- /dev/null
+++ b/spacecadetpinball/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1
+PACKAGE_NAME="spacecadetpinball"
+
+%:
+ dh $@
+
+execute_after_dh_install:
+ mv -f "debian/${PACKAGE_NAME}/usr/bin/SpaceCadetPinball" "debian/${PACKAGE_NAME}/usr/lib/spacecadetpinball"
+ mv -f "debian/${PACKAGE_NAME}/usr/lib/${PACKAGE_NAME}/Sounds"/* "debian/${PACKAGE_NAME}/usr/lib/${PACKAGE_NAME}/"
+ pwd
+ find . ! -type d -exec ls -altrdF --color=always {} +
+
+#override_dh_auto_configure:
+# dh_auto_configure -- \
+# -DCMAKE_LIBRARY_ARCHITECTURE="$(DEB_TARGET_MULTIARCH)"
diff --git a/spacecadetpinball/debian/source/format b/spacecadetpinball/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/spacecadetpinball/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/spacecadetpinball/debian/source/include-binaries b/spacecadetpinball/debian/source/include-binaries
new file mode 100644
index 0000000..77a1160
--- /dev/null
+++ b/spacecadetpinball/debian/source/include-binaries
@@ -0,0 +1,51 @@
+debian/space_cadet/Sounds/*
+debian/space_cadet/WMCONFIG.EXE
+debian/space_cadet/PINBALL.EXE
+debian/space_cadet/PINBALL2.MID
+debian/space_cadet/TABLE.BMP
+debian/space_cadet/PINBALL.MID
+debian/space_cadet/PINBALL.DOC
+debian/space_cadet/FONT.DAT
+debian/space_cadet/PINBALL.DAT
+debian/space_cadet/Sounds/SOUND36.WAV
+debian/space_cadet/Sounds/SOUND43.WAV
+debian/space_cadet/Sounds/SOUND25.WAV
+debian/space_cadet/Sounds/SOUND7.WAV
+debian/space_cadet/Sounds/SOUND54.WAV
+debian/space_cadet/Sounds/SOUND4.WAV
+debian/space_cadet/Sounds/SOUND22.WAV
+debian/space_cadet/Sounds/SOUND14.WAV
+debian/space_cadet/Sounds/SOUND57.WAV
+debian/space_cadet/Sounds/SOUND9.WAV
+debian/space_cadet/Sounds/SOUND3.WAV
+debian/space_cadet/Sounds/SOUND5.WAV
+debian/space_cadet/Sounds/SOUND20.WAV
+debian/space_cadet/Sounds/SOUND108.WAV
+debian/space_cadet/Sounds/SOUND18.WAV
+debian/space_cadet/Sounds/SOUND45.WAV
+debian/space_cadet/Sounds/SOUND8.WAV
+debian/space_cadet/Sounds/SOUND58.WAV
+debian/space_cadet/Sounds/SOUND55.WAV
+debian/space_cadet/Sounds/SOUND105.WAV
+debian/space_cadet/Sounds/SOUND27.WAV
+debian/space_cadet/Sounds/SOUND29.WAV
+debian/space_cadet/Sounds/SOUND16.WAV
+debian/space_cadet/Sounds/SOUND39.WAV
+debian/space_cadet/Sounds/SOUND30.WAV
+debian/space_cadet/Sounds/SOUND1.WAV
+debian/space_cadet/Sounds/SOUND17.WAV
+debian/space_cadet/Sounds/SOUND50.WAV
+debian/space_cadet/Sounds/SOUND131.WAV
+debian/space_cadet/Sounds/SOUND19.WAV
+debian/space_cadet/Sounds/SOUND35.WAV
+debian/space_cadet/Sounds/SOUND21.WAV
+debian/space_cadet/Sounds/SOUND49D.WAV
+debian/space_cadet/Sounds/SOUND12.WAV
+debian/space_cadet/Sounds/SOUND38.WAV
+debian/space_cadet/Sounds/SOUND24.WAV
+debian/space_cadet/Sounds/SOUND28.WAV
+debian/space_cadet/Sounds/SOUND104.WAV
+debian/space_cadet/Sounds/SOUND26.WAV
+debian/space_cadet/Sounds/SOUND34.WAV
+debian/space_cadet/Sounds/SOUND42.WAV
+debian/space_cadet/Sounds/SOUND49.WAV
diff --git a/spacecadetpinball/debian/source/lintian-overrides b/spacecadetpinball/debian/source/lintian-overrides
new file mode 100644
index 0000000..265341b
--- /dev/null
+++ b/spacecadetpinball/debian/source/lintian-overrides
@@ -0,0 +1 @@
+source-contains-prebuilt-windows-binary
diff --git a/spacecadetpinball/debian/spacecadetpinball+stackrpms.dsc b/spacecadetpinball/debian/spacecadetpinball+stackrpms.dsc
new file mode 100644
index 0000000..d0ca8e1
--- /dev/null
+++ b/spacecadetpinball/debian/spacecadetpinball+stackrpms.dsc
@@ -0,0 +1,14 @@
+Format: 3.0 (quilt)
+Source: spacecadetpinball
+Binary: spacecadetpinball
+Architecture: any
+Version: 2.1.0-1+stackrpms
+Maintainer: B. Stack <bgstack15@gmail.com>
+Homepage: https://github.com/k4zmu2a/SpaceCadetPinball
+Standards-Version: 4.6.1
+Build-Depends: debhelper-compat (= 13), cmake, libsdl2-dev, libsdl2-mixer-dev
+Package-List:
+ spacecadetpinball deb games optional arch=any
+Files:
+ 00000000000000000000000000000000 1 spacecadetpinball.orig.tar.gz
+ 00000000000000000000000000000000 1 spacecadetpinball.debian.tar.xz
diff --git a/spacecadetpinball/debian/spacecadetpinball.desktop b/spacecadetpinball/debian/spacecadetpinball.desktop
new file mode 100644
index 0000000..8b8ca1b
--- /dev/null
+++ b/spacecadetpinball/debian/spacecadetpinball.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.4
+Type=Application
+Name=SpaceCadetPinball
+Comment=Reverse engineered port of "3D Pinball for Windows - Space Cadet" to Linux
+Icon=SpaceCadetPinball
+TryExec=spacecadetpinball
+Exec=spacecadetpinball
+Categories=Game;
diff --git a/spacecadetpinball/debian/spacecadetpinball.install b/spacecadetpinball/debian/spacecadetpinball.install
new file mode 100644
index 0000000..263dc0e
--- /dev/null
+++ b/spacecadetpinball/debian/spacecadetpinball.install
@@ -0,0 +1,2 @@
+space_cadet/* usr/lib/spacecadetpinball/
+debian/SpaceCadetPinball usr/games/
diff --git a/spacecadetpinball/debian/spacecadetpinball.lintian-overrides b/spacecadetpinball/debian/spacecadetpinball.lintian-overrides
new file mode 100644
index 0000000..63b12b5
--- /dev/null
+++ b/spacecadetpinball/debian/spacecadetpinball.lintian-overrides
@@ -0,0 +1 @@
+appstream-metadata-validation-failed
diff --git a/spacecadetpinball/debian/spacecadetpinball.manpages b/spacecadetpinball/debian/spacecadetpinball.manpages
new file mode 100644
index 0000000..d5126ba
--- /dev/null
+++ b/spacecadetpinball/debian/spacecadetpinball.manpages
@@ -0,0 +1 @@
+debian/SpaceCadetPinball.1
diff --git a/spacecadetpinball/debian/upstream/metadata b/spacecadetpinball/debian/upstream/metadata
new file mode 100644
index 0000000..dc2feb0
--- /dev/null
+++ b/spacecadetpinball/debian/upstream/metadata
@@ -0,0 +1,16 @@
+#
+# DEP-12: Per-package machine-readable metadata about Upstream
+# Please check * https://dep-team.pages.debian.net/deps/dep12/
+# * https://wiki.debian.org/UpstreamMetadata
+Reference:
+ Author: <please use full names and separate multiple author by the keyword "and">
+ Title:
+ Journal:
+ Year:
+ Volume:
+ Number:
+ Pages:
+ DOI:
+ PMID:
+ URL:
+ eprint:
diff --git a/spacecadetpinball/debian/watch b/spacecadetpinball/debian/watch
new file mode 100644
index 0000000..76575dc
--- /dev/null
+++ b/spacecadetpinball/debian/watch
@@ -0,0 +1,2 @@
+# You must remove unused comment lines for the released package.
+version=3
bgstack15