summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_gcc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'freefilesync/debian/patches/ffs_gcc.patch')
-rw-r--r--freefilesync/debian/patches/ffs_gcc.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/freefilesync/debian/patches/ffs_gcc.patch b/freefilesync/debian/patches/ffs_gcc.patch
index 21a338d..0f7329c 100644
--- a/freefilesync/debian/patches/ffs_gcc.patch
+++ b/freefilesync/debian/patches/ffs_gcc.patch
@@ -1,5 +1,5 @@
-Date: 2022-09-07
-Version: 11.25
+Date: 2023-07-24
+Version: 12.5
Message: Parameterize the C++ compiler invocation, and use g++-12
Author: bgstack15
--- a/FreeFileSync/Source/Makefile
@@ -9,7 +9,7 @@ Author: bgstack15
exeName = FreeFileSync
+CXX=g++-12
- CXXFLAGS += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ CXXFLAGS += -std=c++23 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wnon-virtual-dtor -Wno-unused-function -Wshadow -Wno-maybe-uninitialized \
--- a/FreeFileSync/Source/RealTimeSync/Makefile
+++ b/FreeFileSync/Source/RealTimeSync/Makefile
@@ -18,5 +18,5 @@ Author: bgstack15
exeName = RealTimeSync
+CXX=g++-12
- CXXFLAGS += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ CXXFLAGS += -std=c++23 -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wnon-virtual-dtor -Wno-unused-function -Wshadow -Wno-maybe-uninitialized \
bgstack15