summaryrefslogtreecommitdiff
path: root/yt-dlp/debian/rules
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2021-12-09 15:32:47 -0500
committerB. Stack <bgstack15@gmail.com>2021-12-09 15:32:47 -0500
commit328f444bc77d4323d5eceb93e6d84185322445ba (patch)
treef3e77aacbba7434d363beec3f166e52436d2190d /yt-dlp/debian/rules
parentMerge branch 'irfanview-bump' into 'master' (diff)
downloadstackrpms-328f444bc77d4323d5eceb93e6d84185322445ba.tar.gz
stackrpms-328f444bc77d4323d5eceb93e6d84185322445ba.tar.bz2
stackrpms-328f444bc77d4323d5eceb93e6d84185322445ba.zip
add yt-dlpyt-dlp-bump
Diffstat (limited to 'yt-dlp/debian/rules')
-rwxr-xr-xyt-dlp/debian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/yt-dlp/debian/rules b/yt-dlp/debian/rules
new file mode 100755
index 0000000..9b22958
--- /dev/null
+++ b/yt-dlp/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = yt_dlp
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_configure:
+ PREFIX=/usr SYSCONFDIR=/etc make
+ rm yt-dlp
+
+override_dh_clean:
+ make clean
+ dh_clean CONTRIBUTING.md
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ echo DISABLED FOR STACKRPMS make offlinetest PYTHON=python3
+endif
+
+basenum = $(shell sed -n '/Currently supported sites/=' debian/control)
+generate_supported_sites:
+ $(shell head -n +$$(expr $(basenum) + 1) debian/control > debian/control.new; \
+ sed -n -e 's/.* \- \*\*/ /g' -e 's/:.*//' -e 's/\*\*.*/,/p' supportedsites.md >> debian/control.new)
bgstack15