summaryrefslogtreecommitdiff
path: root/ublock-origin-combined/debian/Makefile
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-10-20 14:14:07 -0400
committerB Stack <bgstack15@gmail.com>2020-10-20 14:14:07 -0400
commitec1b4def96f555245774ae843bdcafff58103168 (patch)
treeb7f982ca20c7f9a6f1d3129e587dd7c58f6202ff /ublock-origin-combined/debian/Makefile
parentMerge branch 'makemkv-bump' into 'master' (diff)
downloadstackrpms-ec1b4def96f555245774ae843bdcafff58103168.tar.gz
stackrpms-ec1b4def96f555245774ae843bdcafff58103168.tar.bz2
stackrpms-ec1b4def96f555245774ae843bdcafff58103168.zip
ublock-origin-combined rc1
First attempt in both rpm and dpkg for a single package that owns ublock-origin. This should simplify maintenance going forward.
Diffstat (limited to 'ublock-origin-combined/debian/Makefile')
-rw-r--r--ublock-origin-combined/debian/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/ublock-origin-combined/debian/Makefile b/ublock-origin-combined/debian/Makefile
new file mode 100644
index 0000000..fca5b8a
--- /dev/null
+++ b/ublock-origin-combined/debian/Makefile
@@ -0,0 +1,19 @@
+# Makefile for palemoon-ublock-origin for devuan
+SOURCE0=uBlock0.firefox-legacy.xpi
+extdir1=/usr/lib/palemoon/browser/extensions
+extdir3=/usr/lib/waterfox/browser/extensions
+extdir4=/usr/lib/newmoon/browser/extensions
+
+# this needs to be overwritten by the debian/rules file.
+DESTDIR=/tmp
+
+install:
+ unzip ${SOURCE0} install.rdf
+ mkdir -p $(DESTDIR)${extdir1}
+ newfilename="$$( grep 'em:id' install.rdf 2>/dev/null | head -n1 | sed -r -e 's/^.*<em:id>//;' -e 's/<\/em:id>.*$$//;' ).xpi" ; \
+ test -z "$${newfilename}" && newfilename="$$( basename $${SOURCE0} )" ; \
+ install -Dp -m0644 ${SOURCE0} $(DESTDIR)${extdir1}/$${newfilename}
+ rm -f install.rdf || :
+
+uninstall:
+ rm -f $(DESTDIR)${extdir1}/uBlock0@raymondhill.net.xpi
bgstack15