summaryrefslogtreecommitdiff
path: root/pasystray/debian/patches
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2024-12-31 12:05:13 -0500
committerB. Stack <bgstack15@gmail.com>2024-12-31 12:05:13 -0500
commit119cdc535c42d88f5123e87a9c357143c4ebfb79 (patch)
tree5d1a01fdb82d3772ac24241f3cb718654705770b /pasystray/debian/patches
parentnpp 8.7.5 (diff)
downloadstackrpms-119cdc535c42d88f5123e87a9c357143c4ebfb79.tar.gz
stackrpms-119cdc535c42d88f5123e87a9c357143c4ebfb79.tar.bz2
stackrpms-119cdc535c42d88f5123e87a9c357143c4ebfb79.zip
add pasystray
Diffstat (limited to 'pasystray/debian/patches')
-rw-r--r--pasystray/debian/patches/0001-Build-against-ayatana-appindicator.patch23
-rw-r--r--pasystray/debian/patches/0002-Require-X11-backend.patch19
-rw-r--r--pasystray/debian/patches/0003-pulsemixer-instead-pavucontrol.patch16
-rw-r--r--pasystray/debian/patches/series2
4 files changed, 60 insertions, 0 deletions
diff --git a/pasystray/debian/patches/0001-Build-against-ayatana-appindicator.patch b/pasystray/debian/patches/0001-Build-against-ayatana-appindicator.patch
new file mode 100644
index 0000000..e01cb6b
--- /dev/null
+++ b/pasystray/debian/patches/0001-Build-against-ayatana-appindicator.patch
@@ -0,0 +1,23 @@
+From: Scott Leggett <scott@sl.id.au>
+Date: Fri, 26 Oct 2018 23:23:06 +1100
+Subject: Build against ayatana-appindicator
+Forwarded: not-needed
+
+---
+ configure.ac | 4 ++--
+ src/systray_impl.c | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -123,8 +123,8 @@ AC_ARG_ENABLE([appindicator],
+ AS_HELP_STRING([--disable-appindicator], [Disable optional appindicator support]))
+
+ case ${with_gtk} in
+- 2) APPINDICATOR_VERSION=appindicator-0.1;;
+- 3) APPINDICATOR_VERSION=appindicator3-0.1;;
++ 2) APPINDICATOR_VERSION=ayatana-appindicator-0.1;;
++ 3) APPINDICATOR_VERSION=ayatana-appindicator3-0.1;;
+ esac
+ AS_IF([test "x$enable_appindicator" != xno],
+ [PKG_CHECK_MODULES(APPINDICATOR, [ $APPINDICATOR_VERSION ], HAVE_APPINDICATOR=1,
diff --git a/pasystray/debian/patches/0002-Require-X11-backend.patch b/pasystray/debian/patches/0002-Require-X11-backend.patch
new file mode 100644
index 0000000..083c98f
--- /dev/null
+++ b/pasystray/debian/patches/0002-Require-X11-backend.patch
@@ -0,0 +1,19 @@
+From: Scott Leggett <scott@sl.id.au>
+Date: Mon, 29 Oct 2018 22:40:16 +1100
+Subject: Require X11 backend
+Forwarded: not-needed
+
+---
+ src/pasystray.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/pasystray.c
++++ b/src/pasystray.c
+@@ -38,6 +38,7 @@ static menu_infos_t* mis;
+
+ int main(int argc, char *argv[])
+ {
++ gdk_set_allowed_backends ("x11");
+ GOptionEntry* options = get_options();
+ GError *error = NULL;
+ gtk_init_with_args(&argc, &argv, NULL, options, NULL, &error);
diff --git a/pasystray/debian/patches/0003-pulsemixer-instead-pavucontrol.patch b/pasystray/debian/patches/0003-pulsemixer-instead-pavucontrol.patch
new file mode 100644
index 0000000..c1991cf
--- /dev/null
+++ b/pasystray/debian/patches/0003-pulsemixer-instead-pavucontrol.patch
@@ -0,0 +1,16 @@
+Author: bgstack15
+Date: 2024-12-31-3 11:55
+Version: 0.8.2
+Message:
+Use my preferred tools.
+--- a/src/systray.c
++++ b/src/systray.c
+@@ -30,7 +30,7 @@
+
+ static const char* COMMAND_PAMAN = "paman";
+ static const char* COMMAND_PAEQUALIZER = "qpaeq";
+-static const char* COMMAND_PAVUCONTROL = "pulsemixer";
++static const char* COMMAND_PAVUCONTROL = "xterm pulsemixer";
+ static const char* COMMAND_PAVUMETER = "pavumeter";
+ static const char* COMMAND_PAVUMETER_REC = "pavumeter --record";
+ static const char* COMMAND_PAPREFS = "paprefs";
diff --git a/pasystray/debian/patches/series b/pasystray/debian/patches/series
new file mode 100644
index 0000000..cc344ec
--- /dev/null
+++ b/pasystray/debian/patches/series
@@ -0,0 +1,2 @@
+0002-Require-X11-backend.patch
+0003-pulsemixer-instead-pavucontrol.patch
bgstack15