summaryrefslogtreecommitdiff
path: root/palemoon-stackrpms-ublock-origin/debian/Makefile
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2019-02-19 14:11:17 -0500
committerB Stack <bgstack15@gmail.com>2019-02-19 14:11:17 -0500
commitc033cdd7200d654ada811d9ef769de96a7c87b0b (patch)
treee3b0ba772fa2d5b0ad3e601126eae22998dcbaaf /palemoon-stackrpms-ublock-origin/debian/Makefile
parentrename pm-stack-ublock spec (diff)
downloadstackrpms-c033cdd7200d654ada811d9ef769de96a7c87b0b.tar.gz
stackrpms-c033cdd7200d654ada811d9ef769de96a7c87b0b.tar.bz2
stackrpms-c033cdd7200d654ada811d9ef769de96a7c87b0b.zip
split pm-ublock into two dirs
Diffstat (limited to 'palemoon-stackrpms-ublock-origin/debian/Makefile')
-rw-r--r--palemoon-stackrpms-ublock-origin/debian/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/palemoon-stackrpms-ublock-origin/debian/Makefile b/palemoon-stackrpms-ublock-origin/debian/Makefile
new file mode 100644
index 0000000..3531a3e
--- /dev/null
+++ b/palemoon-stackrpms-ublock-origin/debian/Makefile
@@ -0,0 +1,17 @@
+# Makefile for palemoon-ublock-origin for devuan
+SOURCE0=uBlock0.firefox-legacy.xpi
+MOZ_EXTENSIONS=/usr/lib/palemoon/browser/extensions
+
+# this needs to be overwritten by the debian/rules file.
+DESTDIR=/tmp
+
+install:
+ unzip ${SOURCE0} install.rdf
+ mkdir -p $(DESTDIR)${MOZ_EXTENSIONS}
+ newfilename="$$( grep 'em:id' install.rdf 2>/dev/null | head -n1 | sed -r -e 's/^.*<em:id>//;' -e 's/<\/em:id>.*$$//;' ).xpi" ; \
+ test -z "$${newfilename}" && newfilename="$$( basename $${SOURCE0} )" ; \
+ install -Dp -m0644 ${SOURCE0} $(DESTDIR)${MOZ_EXTENSIONS}/$${newfilename}
+ rm -f install.rdf || :
+
+uninstall:
+ rm -f $(DESTDIR)${MOZ_EXTENSIONS}/uBlock0@raymondhill.net.xpi
bgstack15