summaryrefslogtreecommitdiff
path: root/newmoon/debian/rules
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2023-02-25 13:22:17 +0000
committerB. Stack <bgstack15@gmail.com>2023-02-25 13:22:17 +0000
commit1a5864d1ca0c6b1d556ad762271d8ea6bf9228b9 (patch)
treee9ef3b12c5f2edaabed1a7dedc4ca9d64bcd2758 /newmoon/debian/rules
parentMerge branch 'freefilesync-bump' into 'master' (diff)
parentnewmoon spec handles perl in fc38 (diff)
downloadstackrpms-1a5864d1ca0c6b1d556ad762271d8ea6bf9228b9.tar.gz
stackrpms-1a5864d1ca0c6b1d556ad762271d8ea6bf9228b9.tar.bz2
stackrpms-1a5864d1ca0c6b1d556ad762271d8ea6bf9228b9.zip
Merge branch 'newmoon-bump' into 'master'
newmoon 32.0.1 See merge request bgstack15/stackrpms!341
Diffstat (limited to 'newmoon/debian/rules')
-rwxr-xr-xnewmoon/debian/rules18
1 files changed, 5 insertions, 13 deletions
diff --git a/newmoon/debian/rules b/newmoon/debian/rules
index 89ddd3f..bc24b7b 100755
--- a/newmoon/debian/rules
+++ b/newmoon/debian/rules
@@ -2,18 +2,10 @@
export SHELL=/bin/bash
-## borrowed from stevepusser's logic
-## Build with gcc-10 on releases where default gcc is 11
-## If you enable this, then d/control needs lsb-release as a build dependency.
-#distrelease := $(shell lsb_release -cs)
-#ifeq ($(distrelease),$(filter $(distrelease),sid beowulf/ceres))
-export CC=gcc-10
-export CXX=g++-10
-export CPP=cpp-10
-export LD=gcc-10
-#endif
-
-export MCFILE=debian/mozconfig
+ifneq (,$(filter $(DEB_HOST_ARCH), armhf))
+ export DEB_CFLAGS_MAINT_APPEND = -mfpu=neon -funsafe-math-optimizations
+ export DEB_CXXFLAGS_MAINT_APPEND = -mfpu=neon -funsafe-math-optimizations
+endif
%:
dh $@ --without autoreconf
@@ -28,7 +20,7 @@ override_dh_auto_clean:
} || :
override_dh_auto_configure:
- cp ${MCFILE} mozconfig
+ cp debian/mozconfig mozconfig
! test -d palemoon/branding/unofficial.unbuilt && { \
cp -pr palemoon/branding/unofficial palemoon/branding/unofficial.unbuilt && \
tar -C palemoon/branding -zxf debian/bluemoon-icons.tgz ; } || :
bgstack15