summaryrefslogtreecommitdiff
path: root/mediaelch/debian/rules
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2024-04-06 09:14:31 -0400
committerB. Stack <bgstack15@gmail.com>2024-04-06 09:14:31 -0400
commit8f23e8b1abb8f99e3e926edb6f7321b61c544c17 (patch)
treed0259c84289d4eb3573bb248017e18fa5b49d09d /mediaelch/debian/rules
parentadd mediaelch (diff)
downloadstackrpms-8f23e8b1abb8f99e3e926edb6f7321b61c544c17.tar.gz
stackrpms-8f23e8b1abb8f99e3e926edb6f7321b61c544c17.tar.bz2
stackrpms-8f23e8b1abb8f99e3e926edb6f7321b61c544c17.zip
try qt6 stuff for obs
Diffstat (limited to 'mediaelch/debian/rules')
-rwxr-xr-xmediaelch/debian/rules13
1 files changed, 9 insertions, 4 deletions
diff --git a/mediaelch/debian/rules b/mediaelch/debian/rules
index cb7f216..6dc3662 100755
--- a/mediaelch/debian/rules
+++ b/mediaelch/debian/rules
@@ -1,9 +1,14 @@
#!/usr/bin/make -f
-QT_SELECT=qt5
-export QT_SELECT
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/qmake.mk
+export QT_SELECT = 6
+%:
+ dh $@
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -DUSE_EXTERN_QUAZIP:BOOL=ON
bgstack15