summaryrefslogtreecommitdiff
path: root/freefilesync/debian
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2023-04-03 10:06:31 -0400
committerB. Stack <bgstack15@gmail.com>2023-04-03 10:07:04 -0400
commit843625d725ca6bbb22a957446813790a1a000e34 (patch)
treee57a448fd3727fa02aa9f521a4d210c4613492f7 /freefilesync/debian
parentmerge (diff)
downloadstackrpms-843625d725ca6bbb22a957446813790a1a000e34.tar.gz
stackrpms-843625d725ca6bbb22a957446813790a1a000e34.tar.bz2
stackrpms-843625d725ca6bbb22a957446813790a1a000e34.zip
ffs 12.2 rc1
Diffstat (limited to 'freefilesync/debian')
-rw-r--r--freefilesync/debian/_service4
-rw-r--r--freefilesync/debian/changelog15
-rw-r--r--freefilesync/debian/freefilesync+stackrpms.dsc2
-rw-r--r--freefilesync/debian/patches/ffs_tooltips_no_taskbar.patch12
4 files changed, 24 insertions, 9 deletions
diff --git a/freefilesync/debian/_service b/freefilesync/debian/_service
index 4fa92de..f269167 100644
--- a/freefilesync/debian/_service
+++ b/freefilesync/debian/_service
@@ -1,7 +1,7 @@
<services>
<service name="tar_scm">
<param name="scm">git</param>
- <param name="url">https://gitlab.com/bgstack15/stackrpms.git</param>
+ <param name="url">https://bgstack15.ddns.net/cgit/stackrpms</param>
<param name="subdir">freefilesync/debian</param>
<param name="filename">debian</param>
<param name="revision">freefilesync-bump</param>
@@ -14,7 +14,7 @@
<service name="tar_scm">
<param name="scm">git</param>
<param name="url">https://gitlab.com/opensource-tracking/FreeFileSync.git</param>
- <param name="revision">12.1</param>
+ <param name="revision">12.2</param>
<param name="version">_none_</param>
</service>
<service name="recompress">
diff --git a/freefilesync/debian/changelog b/freefilesync/debian/changelog
index cd16dc2..15aa19c 100644
--- a/freefilesync/debian/changelog
+++ b/freefilesync/debian/changelog
@@ -1,3 +1,18 @@
+freefilesync (12.2-100+stackrpms) obs; urgency=low
+
+ * Upstream updates
+ * Fixed temporary access error when creating multiple folders in
+ parallel
+ * Log failure to copy folder attributes as warning only
+ * Enable UTF-8, even if FTP server does not advertize in FEAT (vsftpd)
+ * Fixed drag and drop for non-ASCII folders (macOS)
+ * Explicitly detect MTP path without existence check
+ * Fixed crash when parsing SFTP package from stream
+ * Revert back to GTK2 build due to GTK3 hangs on KDE (Linux)
+ * Fixed missing COM initialization for MTP path parsing
+
+ -- B. Stack <bgstack15@gmail.com> Mon, 03 Apr 2023 10:00:22 -0400
+
freefilesync (12.1-100+stackrpms) obs; urgency=low
* Upstream updates
diff --git a/freefilesync/debian/freefilesync+stackrpms.dsc b/freefilesync/debian/freefilesync+stackrpms.dsc
index f8e6e36..1c42ad6 100644
--- a/freefilesync/debian/freefilesync+stackrpms.dsc
+++ b/freefilesync/debian/freefilesync+stackrpms.dsc
@@ -2,7 +2,7 @@ Format: 3.0 (quilt)
Source: freefilesync
Binary: freefilesync
Architecture: any
-Version: 12.1-100+stackrpms
+Version: 12.2-100+stackrpms
Maintainer: B. Stack <bgstack15@gmail.com>
Homepage: https://freefilesync.org/
Standards-Version: 4.1.4
diff --git a/freefilesync/debian/patches/ffs_tooltips_no_taskbar.patch b/freefilesync/debian/patches/ffs_tooltips_no_taskbar.patch
index 7f2443d..15948d2 100644
--- a/freefilesync/debian/patches/ffs_tooltips_no_taskbar.patch
+++ b/freefilesync/debian/patches/ffs_tooltips_no_taskbar.patch
@@ -1,7 +1,7 @@
-Version: 12.0
-Date: 2023-01-22
+Version: 12.2
+Date: 2023-04-03
Author: bgstack15
-Message: Suppress taskbar entry for tooltip "window"
+Message: Suppress taskbar entry for tooltip "window". Upstream declined this patch (https://freefilesync.org/forum/viewtopic.php?t=9898) so it must continue here.
--- a/wx+/tooltip.cpp
+++ b/wx+/tooltip.cpp
@@ -9,6 +9,7 @@
@@ -16,8 +16,8 @@ Message: Suppress taskbar entry for tooltip "window"
{
public:
TooltipDlgGenerated(wxWindow* parent) : //Suse Linux/X11: needs parent window, else there are z-order issues
-- wxDialog(parent, wxID_ANY, L"" /*title*/, wxDefaultPosition, wxDefaultSize, 0 /*style*/)
-+ wxDialog(parent, wxID_ANY, L"" /*title*/, wxDefaultPosition, wxDefaultSize, wxFRAME_NO_TASKBAR /*style*/)
+- wxDialog(parent, wxID_ANY, L"" /*title*/, wxDefaultPosition, wxDefaultSize, wxSIMPLE_BORDER /*style*/)
++ wxDialog(parent, wxID_ANY, L"" /*title*/, wxDefaultPosition, wxDefaultSize, wxSIMPLE_BORDER | wxFRAME_NO_TASKBAR /*style*/)
+ //wxSIMPLE_BORDER side effect: removes title bar on KDE
{
SetSizeHints(wxDefaultSize, wxDefaultSize);
- SetExtraStyle(this->GetExtraStyle() | wxWS_EX_TRANSIENT);
bgstack15