summaryrefslogtreecommitdiff
path: root/freefilesync/debian
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2022-12-16 22:52:59 -0500
committerB. Stack <bgstack15@gmail.com>2022-12-16 22:53:40 -0500
commit06ef93c94a30a534fedca041e56bce3fb1cd7929 (patch)
treea09a89c3a8601cbab5ab0ac4f9dde740722d417a /freefilesync/debian
parentMerge branch 'scite-bump' into 'master' (diff)
downloadstackrpms-06ef93c94a30a534fedca041e56bce3fb1cd7929.tar.gz
stackrpms-06ef93c94a30a534fedca041e56bce3fb1cd7929.tar.bz2
stackrpms-06ef93c94a30a534fedca041e56bce3fb1cd7929.zip
ffs 11.29 rc1
Diffstat (limited to 'freefilesync/debian')
-rw-r--r--freefilesync/debian/_service2
-rw-r--r--freefilesync/debian/changelog23
-rw-r--r--freefilesync/debian/freefilesync+devuan.dsc2
-rw-r--r--freefilesync/debian/patches/ffs_no_check_updates.patch84
-rw-r--r--freefilesync/debian/patches/ffs_tooltips_no_taskbar.patch23
-rw-r--r--freefilesync/debian/patches/series1
6 files changed, 91 insertions, 44 deletions
diff --git a/freefilesync/debian/_service b/freefilesync/debian/_service
index be231e7..976c025 100644
--- a/freefilesync/debian/_service
+++ b/freefilesync/debian/_service
@@ -14,7 +14,7 @@
<service name="tar_scm">
<param name="scm">git</param>
<param name="url">https://gitlab.com/opensource-tracking/FreeFileSync.git</param>
- <param name="revision">11.28</param>
+ <param name="revision">11.29</param>
<param name="version">_none_</param>
</service>
<service name="recompress">
diff --git a/freefilesync/debian/changelog b/freefilesync/debian/changelog
index 1a1b9de..76175a7 100644
--- a/freefilesync/debian/changelog
+++ b/freefilesync/debian/changelog
@@ -1,3 +1,26 @@
+freefilesync (11.29-1+devuan) obs; urgency=low
+
+ * Upstream updates
+ * Fixed crash after 1-byte file copy from MTP device
+ * Fixed incorrect installer z-order during auto-update (macOS)
+ * Compress copied file only if target folder is marked as
+ NTFS-compressed (Windows)
+ * Show install errors without requiring access to "System Events"
+ (macOS)
+ * Fall back to creation time if modification time is missing on MTP
+ device
+ * Copy/paste filter config via operating system clipboard
+ * Show FreeFileSync startup error message when called from RealTimeSync
+ * Avoid server round trip when preparing summary email
+ * Show path conflict warning aggregated into groups
+ * Don't assume path conflict if single write and multiple ignored items
+ * Fixed CTRL + Insert clipboard copy for some text controls (Windows,
+ Linux)
+ * Dpkg updates
+ * Add ffs_tooltips_no_taskbar patch
+
+ -- B. Stack <bgstack15@gmail.com> Fri, 16 Dec 2022 21:12:02 -0500
+
freefilesync (11.28-1+devuan) obs; urgency=low
* Upstream updates
diff --git a/freefilesync/debian/freefilesync+devuan.dsc b/freefilesync/debian/freefilesync+devuan.dsc
index ff1bfc5..b3b8ae0 100644
--- a/freefilesync/debian/freefilesync+devuan.dsc
+++ b/freefilesync/debian/freefilesync+devuan.dsc
@@ -2,7 +2,7 @@ Format: 3.0 (quilt)
Source: freefilesync
Binary: freefilesync
Architecture: any
-Version: 11.28-1+devuan
+Version: 11.29-1+devuan
Maintainer: B. Stack <bgstack15@gmail.com>
Homepage: https://freefilesync.org/
Standards-Version: 4.1.4
diff --git a/freefilesync/debian/patches/ffs_no_check_updates.patch b/freefilesync/debian/patches/ffs_no_check_updates.patch
index 005f662..f6d02f1 100644
--- a/freefilesync/debian/patches/ffs_no_check_updates.patch
+++ b/freefilesync/debian/patches/ffs_no_check_updates.patch
@@ -1,57 +1,57 @@
-Version: 11.28
-Date: 2022-11-22
+Version: 11.29
+Date: 2022-12-16
Author: bgstack15
Message: This is a major rewrite of the ffs_no_check_updates patch from before 11.10 which disabled only a few technical www interactions. This current version completely deletes all logic associated with checking the version of the program.
--- a/FreeFileSync/Source/ui/gui_generated.cpp
+++ b/FreeFileSync/Source/ui/gui_generated.cpp
@@ -110,15 +110,6 @@ MainDialogGenerated::MainDialogGenerated
- m_menuHelp->AppendSeparator();
+ m_menuHelp->AppendSeparator();
-- m_menuItemCheckVersionNow = new wxMenuItem( m_menuHelp, wxID_ANY, wxString( _("&Check for updates now") ), wxEmptyString, wxITEM_NORMAL );
-- m_menuHelp->Append( m_menuItemCheckVersionNow );
+- m_menuItemCheckVersionNow = new wxMenuItem( m_menuHelp, wxID_ANY, wxString( _("&Check for updates now") ) , wxEmptyString, wxITEM_NORMAL );
+- m_menuHelp->Append( m_menuItemCheckVersionNow );
-
-- m_menuItemCheckVersionAuto = new wxMenuItem( m_menuHelp, wxID_ANY, wxString( _("Check &automatically once a week") ), wxEmptyString, wxITEM_CHECK );
-- m_menuHelp->Append( m_menuItemCheckVersionAuto );
-- m_menuItemCheckVersionAuto->Check( true );
+- m_menuItemCheckVersionAuto = new wxMenuItem( m_menuHelp, wxID_ANY, wxString( _("Check &automatically once a week") ) , wxEmptyString, wxITEM_CHECK );
+- m_menuHelp->Append( m_menuItemCheckVersionAuto );
+- m_menuItemCheckVersionAuto->Check( true );
-
-- m_menuHelp->AppendSeparator();
+- m_menuHelp->AppendSeparator();
-
- m_menuItemAbout = new wxMenuItem( m_menuHelp, wxID_ABOUT, wxString( _("&About") ) + wxT('\t') + wxT("Shift+F1"), wxEmptyString, wxITEM_NORMAL );
- m_menuHelp->Append( m_menuItemAbout );
+ m_menuItemAbout = new wxMenuItem( m_menuHelp, wxID_ABOUT, wxString( _("&About") ) + wxT('\t') + wxT("Shift+F1"), wxEmptyString, wxITEM_NORMAL );
+ m_menuHelp->Append( m_menuItemAbout );
@@ -1129,8 +1120,6 @@ MainDialogGenerated::MainDialogGenerated
- m_menuTools->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuExportFileList ), this, m_menuItemExportList->GetId());
- m_menuTools->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuResetLayout ), this, m_menuItemResetLayout->GetId());
- m_menuHelp->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onShowHelp ), this, m_menuItemHelp->GetId());
-- m_menuHelp->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuCheckVersion ), this, m_menuItemCheckVersionNow->GetId());
-- m_menuHelp->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuCheckVersionAutomatically ), this, m_menuItemCheckVersionAuto->GetId());
- m_menuHelp->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuAbout ), this, m_menuItemAbout->GetId());
- m_buttonCompare->Connect( wxEVT_COMMAND_BUTTON_CLICKED, wxCommandEventHandler( MainDialogGenerated::onCompare ), NULL, this );
- m_bpButtonCmpConfig->Connect( wxEVT_COMMAND_BUTTON_CLICKED, wxCommandEventHandler( MainDialogGenerated::onCmpSettings ), NULL, this );
+ m_menuTools->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuExportFileList ), this, m_menuItemExportList->GetId());
+ m_menuTools->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuResetLayout ), this, m_menuItemResetLayout->GetId());
+ m_menuHelp->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onShowHelp ), this, m_menuItemHelp->GetId());
+- m_menuHelp->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuCheckVersion ), this, m_menuItemCheckVersionNow->GetId());
+- m_menuHelp->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuCheckVersionAutomatically ), this, m_menuItemCheckVersionAuto->GetId());
+ m_menuHelp->Bind(wxEVT_COMMAND_MENU_SELECTED, wxCommandEventHandler( MainDialogGenerated::onMenuAbout ), this, m_menuItemAbout->GetId());
+ m_buttonCompare->Connect( wxEVT_COMMAND_BUTTON_CLICKED, wxCommandEventHandler( MainDialogGenerated::onCompare ), NULL, this );
+ m_bpButtonCmpConfig->Connect( wxEVT_COMMAND_BUTTON_CLICKED, wxCommandEventHandler( MainDialogGenerated::onCmpSettings ), NULL, this );
--- a/FreeFileSync/Source/ui/gui_generated.h
+++ b/FreeFileSync/Source/ui/gui_generated.h
-@@ -96,8 +96,6 @@ protected:
- wxMenuItem* m_menuItemShowOverview;
- wxMenu* m_menuHelp;
- wxMenuItem* m_menuItemHelp;
-- wxMenuItem* m_menuItemCheckVersionNow;
-- wxMenuItem* m_menuItemCheckVersionAuto;
- wxMenuItem* m_menuItemAbout;
- wxBoxSizer* bSizerPanelHolder;
- wxPanel* m_panelTopButtons;
-@@ -234,8 +232,6 @@ protected:
- virtual void onMenuExportFileList( wxCommandEvent& event ) { event.Skip(); }
- virtual void onMenuResetLayout( wxCommandEvent& event ) { event.Skip(); }
- virtual void onShowHelp( wxCommandEvent& event ) { event.Skip(); }
-- virtual void onMenuCheckVersion( wxCommandEvent& event ) { event.Skip(); }
-- virtual void onMenuCheckVersionAutomatically( wxCommandEvent& event ) { event.Skip(); }
- virtual void onMenuAbout( wxCommandEvent& event ) { event.Skip(); }
- virtual void onCompSettingsContextMouse( wxMouseEvent& event ) { event.Skip(); }
- virtual void onCompSettingsContext( wxCommandEvent& event ) { event.Skip(); }
+@@ -96,8 +96,6 @@ class MainDialogGenerated : public wxFra
+ wxMenuItem* m_menuItemShowOverview;
+ wxMenu* m_menuHelp;
+ wxMenuItem* m_menuItemHelp;
+- wxMenuItem* m_menuItemCheckVersionNow;
+- wxMenuItem* m_menuItemCheckVersionAuto;
+ wxMenuItem* m_menuItemAbout;
+ wxBoxSizer* bSizerPanelHolder;
+ wxPanel* m_panelTopButtons;
+@@ -234,8 +232,6 @@ class MainDialogGenerated : public wxFra
+ virtual void onMenuExportFileList( wxCommandEvent& event ) { event.Skip(); }
+ virtual void onMenuResetLayout( wxCommandEvent& event ) { event.Skip(); }
+ virtual void onShowHelp( wxCommandEvent& event ) { event.Skip(); }
+- virtual void onMenuCheckVersion( wxCommandEvent& event ) { event.Skip(); }
+- virtual void onMenuCheckVersionAutomatically( wxCommandEvent& event ) { event.Skip(); }
+ virtual void onMenuAbout( wxCommandEvent& event ) { event.Skip(); }
+ virtual void onCompSettingsContextMouse( wxMouseEvent& event ) { event.Skip(); }
+ virtual void onCompSettingsContext( wxCommandEvent& event ) { event.Skip(); }
--- a/FreeFileSync/Source/ui/main_dlg.cpp
+++ b/FreeFileSync/Source/ui/main_dlg.cpp
-@@ -31,7 +31,6 @@
+@@ -30,7 +30,6 @@
#include <wx+/window_tools.h>
#include <wx+/image_resources.h>
#include "cfg_grid.h"
@@ -59,7 +59,7 @@ Message: This is a major rewrite of the ffs_no_check_updates patch from before 1
#include "gui_status_handler.h"
#include "small_dlgs.h"
#include "progress_indicator.h"
-@@ -830,7 +829,6 @@ imgFileManagerSmall_([]
+@@ -828,7 +827,6 @@ imgFileManagerSmall_([]
setImage(*m_menuItemHelp, loadImage("help_sicon"));
setImage(*m_menuItemAbout, loadImage("about_sicon"));
@@ -67,7 +67,7 @@ Message: This is a major rewrite of the ffs_no_check_updates patch from before 1
fixMenuIcons(*m_menuFile);
fixMenuIcons(*m_menuActions);
-@@ -930,9 +928,6 @@ imgFileManagerSmall_([]
+@@ -928,9 +926,6 @@ imgFileManagerSmall_([]
//mainly to update row label sizes...
updateGui();
@@ -77,7 +77,7 @@ Message: This is a major rewrite of the ffs_no_check_updates patch from before 1
//asynchronous call to wxWindow::Layout(): fix superfluous frame on right and bottom when FFS is started in fullscreen mode
Bind(wxEVT_IDLE, &MainDialog::onLayoutWindowAsync, this);
wxCommandEvent evtDummy; //call once before onLayoutWindowAsync()
-@@ -1126,8 +1121,6 @@ void MainDialog::setGlobalCfgOnInit(cons
+@@ -1124,8 +1119,6 @@ void MainDialog::setGlobalCfgOnInit(cons
auiMgr_.GetPane(m_panelSearch).Hide(); //no need to show it on startup
auiMgr_.GetPane(m_panelLog ).Hide(); //
@@ -86,7 +86,7 @@ Message: This is a major rewrite of the ffs_no_check_updates patch from before 1
auiMgr_.Update();
}
-@@ -5831,72 +5824,6 @@ void MainDialog::onMenuExportFileList(wx
+@@ -5821,72 +5814,6 @@ void MainDialog::onMenuExportFileList(wx
}
}
diff --git a/freefilesync/debian/patches/ffs_tooltips_no_taskbar.patch b/freefilesync/debian/patches/ffs_tooltips_no_taskbar.patch
new file mode 100644
index 0000000..9a5f114
--- /dev/null
+++ b/freefilesync/debian/patches/ffs_tooltips_no_taskbar.patch
@@ -0,0 +1,23 @@
+Date: 2022-12-16
+Author: bgstack15
+Version: 11.29
+Message: Suppress taskbar entry for tooltip "window"
+--- a/wx+/tooltip.cpp
++++ b/wx+/tooltip.cpp
+@@ -9,6 +9,7 @@
+ #include <wx/sizer.h>
+ #include <wx/statbmp.h>
+ #include <wx/settings.h>
++#include <wx/frame.h>
+ #include <wx/app.h>
+ #include "image_tools.h"
+ #include "bitmap_button.h"
+@@ -27,7 +28,7 @@ const int TIP_WINDOW_OFFSET_DIP = 30;
+ class Tooltip::TooltipDlgGenerated : public wxDialog
+ {
+ public:
+- TooltipDlgGenerated(wxWindow* parent) : wxDialog(parent, wxID_ANY, L"" /*title*/, wxDefaultPosition, wxDefaultSize, 0 /*style*/)
++ TooltipDlgGenerated(wxWindow* parent) : wxDialog(parent, wxID_ANY, L"" /*title*/, wxDefaultPosition, wxDefaultSize, wxFRAME_NO_TASKBAR /*style*/)
+ {
+ //Suse Linux/X11: needs parent window, else there are z-order issues
+
diff --git a/freefilesync/debian/patches/series b/freefilesync/debian/patches/series
index 500443c..68c4830 100644
--- a/freefilesync/debian/patches/series
+++ b/freefilesync/debian/patches/series
@@ -12,3 +12,4 @@ ffs_traditional_view.patch
ffs_desktop_notifications.patch
#ffs_openssl.patch
ffs_icon_loader.patch
+ffs_tooltips_no_taskbar.patch
bgstack15