summaryrefslogtreecommitdiff
path: root/freefilesync/debian/patches/ffs_gcc.patch
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2022-04-21 13:35:31 +0000
committerB. Stack <bgstack15@gmail.com>2022-04-21 13:35:31 +0000
commitcbc5363fef64c2146d03a8f5c2d290db968f2d63 (patch)
tree0c616e0cddf96f96eff40cd4d0b07085a1fa73b6 /freefilesync/debian/patches/ffs_gcc.patch
parentMerge branch 'notepadnext-bump' into 'master' (diff)
parentffs 11.20 rc1 for fedora (diff)
downloadstackrpms-cbc5363fef64c2146d03a8f5c2d290db968f2d63.tar.gz
stackrpms-cbc5363fef64c2146d03a8f5c2d290db968f2d63.tar.bz2
stackrpms-cbc5363fef64c2146d03a8f5c2d290db968f2d63.zip
Merge branch 'freefilesync-bump' into 'master'
FreeFileSync 11.20 See merge request bgstack15/stackrpms!296
Diffstat (limited to 'freefilesync/debian/patches/ffs_gcc.patch')
-rw-r--r--freefilesync/debian/patches/ffs_gcc.patch12
1 files changed, 8 insertions, 4 deletions
diff --git a/freefilesync/debian/patches/ffs_gcc.patch b/freefilesync/debian/patches/ffs_gcc.patch
index 1f34404..dd9e628 100644
--- a/freefilesync/debian/patches/ffs_gcc.patch
+++ b/freefilesync/debian/patches/ffs_gcc.patch
@@ -1,11 +1,15 @@
+Date: 2022-04-18
+Version: 11.20
+Message: Parameterize the C++ compiler invocation
+Author: bgstack15
diff -aur 11.2-1/FreeFileSync/Source/Makefile 11.2-2/FreeFileSync/Source/Makefile
--- 11.2-1/FreeFileSync/Source/Makefile 2020-10-02 14:59:35.816639878 -0400
+++ 11.2-2/FreeFileSync/Source/Makefile 2020-10-02 14:59:54.220866929 -0400
@@ -1,4 +1,5 @@
exeName = FreeFileSync
-+CXX=g++-10
++CXX=g++-11
- cxxFlags += -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ cxxFlags += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../.. -I../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wnon-virtual-dtor -Wno-unused-function -Wshadow -Wno-maybe-uninitialized \
@@ -115,11 +116,11 @@
@@ -26,9 +30,9 @@ diff -aur 11.2-1/FreeFileSync/Source/RealTimeSync/Makefile 11.2-2/FreeFileSync/S
+++ 11.2-2/FreeFileSync/Source/RealTimeSync/Makefile 2020-10-02 14:59:54.220866929 -0400
@@ -1,4 +1,5 @@
exeName = RealTimeSync
-+CXX=g++-10
++CXX=g++-11
- cxxFlags += -std=c++2a -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
+ cxxFlags += -std=c++2b -pipe -DWXINTL_NO_GETTEXT_MACRO -I../../.. -I../../../zenXml -include "zen/i18n.h" -include "zen/warn_static.h" \
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wnon-virtual-dtor -Wno-unused-function -Wshadow -Wno-maybe-uninitialized \
@@ -54,11 +55,11 @@
bgstack15