summaryrefslogtreecommitdiff
path: root/dosbox-x/debian/rules
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2023-05-25 07:42:54 -0400
committerB. Stack <bgstack15@gmail.com>2023-05-25 07:42:54 -0400
commit1d67c517a8ed6f368e833c0a6cf00b70df84fef9 (patch)
tree04ebf128f106d042d9445a5243968f4ee976982d /dosbox-x/debian/rules
parentMerge branch 'notepadnext-bump' into 'master' (diff)
downloadstackrpms-1d67c517a8ed6f368e833c0a6cf00b70df84fef9.tar.gz
stackrpms-1d67c517a8ed6f368e833c0a6cf00b70df84fef9.tar.bz2
stackrpms-1d67c517a8ed6f368e833c0a6cf00b70df84fef9.zip
add initial dosbox-x package
Diffstat (limited to 'dosbox-x/debian/rules')
-rwxr-xr-xdosbox-x/debian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/dosbox-x/debian/rules b/dosbox-x/debian/rules
new file mode 100755
index 0000000..cf6e067
--- /dev/null
+++ b/dosbox-x/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export JAVA_HOME=/usr/lib/jvm/default-java
+export CLASSPATH=/usr/share/java/csv.jar:/usr/share/java/debug-disable.jar:/usr/share/java/itext.jar
+
+%:
+ dh $@ --with javahelper,autoreconf
+
+override_dh_autoreconf:
+ dh_autoreconf -- ./autogen.sh
+
+override_dh_auto_configure:
+ #./configure --enable-core-inline --enable-debug=heavy --enable-sdl2
+ dh_auto_configure -- \
+ --enable-core-inline \
+ --enable-debug=heavy \
+ --enable-sdl2
+
+#override_dh_install:
+# dh_install --list-missing -X.la -X.pyc -X.pyo
bgstack15