aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2022-02-15 22:49:00 -0500
committerB. Stack <bgstack15@gmail.com>2022-02-15 22:49:00 -0500
commitdf2fbdc9bd4387ee72d2b38df9abf0778175c2d4 (patch)
tree763dae2b1480e10e82427c476434802523474d27 /debian/rules
parentsuppress useless stuff from auth (diff)
downloadstackbin-df2fbdc9bd4387ee72d2b38df9abf0778175c2d4.tar.gz
stackbin-df2fbdc9bd4387ee72d2b38df9abf0778175c2d4.tar.bz2
stackbin-df2fbdc9bd4387ee72d2b38df9abf0778175c2d4.zip
add initial debian package recipe
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b123419
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export APPNAME=stackbin
+
+%:
+ dh $@ --sourcedirectory=extra
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr \
+ DEFAULTDIR='$$(DESTDIR)/etc/default' \
+ APACHEDIR='$$(SYSCONFDIR)/apache2/sites-available'
+
+override_dh_gencontrol:
+ printf "misc:Depends=" > debian/${APPNAME}.substvars
+ make -C extra DISTRO=devuan deplist SEPARATOR=',' | grep -vE 'make\[[0-9]' >> debian/${APPNAME}.substvars
+ dh_gencontrol
bgstack15