aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..487c90d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+#!/usr/bin/env python3
+
+import glob
+import os
+import re
+
+from setuptools import setup
+
+init_path = os.path.join(os.path.dirname(__file__),
+ "radicale_web", "__init__.py")
+with open(init_path) as f:
+ version = re.search(r'VERSION = "([^"]+)"', f.read()).group(1)
+os.chdir("radicale_web")
+web_data = glob.glob("web/**/*[!~]", recursive=True)
+os.chdir(os.pardir)
+
+setup(
+ name="Radicale_Web",
+ version=version,
+ description="Web interface for Radicale",
+ author="Unrud",
+ author_email="unrud@openaliasbox.org",
+ url="http://github.com/Unrud/RadicaleWeb",
+ license="GNU AGPL v3",
+ platforms="Any",
+ packages=["radicale_web"],
+ package_data={"radicale_web": web_data})
bgstack15