aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorCédric Bonhomme <cedric@cedricbonhomme.org>2021-07-03 23:24:45 +0200
committerCédric Bonhomme <cedric@cedricbonhomme.org>2021-07-03 23:24:45 +0200
commite6792258a3705da79115738d7f6a0b3876c8d61a (patch)
tree2c370638545b1b3002723c667ee0adc9165f892e /pyproject.toml
parentupdated bootstrap and various UI fixes (diff)
downloadnewspipe-e6792258a3705da79115738d7f6a0b3876c8d61a.tar.gz
newspipe-e6792258a3705da79115738d7f6a0b3876c8d61a.tar.bz2
newspipe-e6792258a3705da79115738d7f6a0b3876c8d61a.zip
updated Python dependencies.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml38
1 files changed, 19 insertions, 19 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 947df1fd..b9ca751a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -7,35 +7,35 @@ license = "AGPL-3.0-or-later"
[tool.poetry.dependencies]
python = "^3.8"
-aiohttp = "^3.6.2"
-requests = "^2.23.0"
-chardet = "^3.0.4"
+aiohttp = "^3.7.4"
+requests = "^2.25.1"
+chardet = "^4.0.0"
requests-futures = "^1.0.0"
-beautifulsoup4 = "^4.8.2"
-lxml = "^4.5.0"
+beautifulsoup4 = "^4.9.3"
+lxml = "^4.6.3"
opml = "^0.5"
-SQLAlchemy = "^1.3.13"
-alembic = "^1.4.0"
-Flask = "^1.1.1"
-Flask-SQLAlchemy = "^2.4.1"
+SQLAlchemy = "^1.4.20"
+alembic = "^1.6.5"
+Flask = "^2.0.1"
+Flask-SQLAlchemy = "^2.5.1"
Flask-Login = "^0.5.0"
Flask-Principal = "^0.4.0"
-Flask-WTF = "^0.14.3"
-Flask-RESTful = "^0.3.8"
-Flask-paginate = "^0.5.5"
-Flask-Babel = "^1.0.0"
-Flask-Migrate = "^2.5.2"
-WTForms = "^2.2.1"
+Flask-WTF = "^0.15.1"
+Flask-RESTful = "^0.3.9"
+Flask-paginate = "^0.8.1"
+Flask-Babel = "^2.0.0"
+Flask-Migrate = "^3.0.1"
+WTForms = "^2.3.3"
python-dateutil = "^2.8.1"
-psycopg2-binary = "^2.8.4"
-flask-talisman = "^0.7.0"
-feedparser = "^6.0.2"
+psycopg2-binary = "^2.9.1"
+flask-talisman = "^0.8.1"
+feedparser = "^6.0.8"
[tool.poetry.dev-dependencies]
sqlalchemy-schemadisplay = "^1.3"
-flake8 = "^3.7.9"
+flake8 = "^3.9.2"
[build-system]
requires = ["poetry>=0.12"]
bgstack15