aboutsummaryrefslogtreecommitdiff
path: root/myautomount.spec
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-09-29 21:05:42 -0400
committerB Stack <bgstack15@gmail.com>2020-09-29 21:05:42 -0400
commit5a757b0f96c60e3d894e8c5a9fd335f91fffb7f9 (patch)
treed57d6e4e1e63641bfc41d6659516d82c2e24d568 /myautomount.spec
parentWIP: fixing initialize for packaging process (diff)
downloadmyautomount-5a757b0f96c60e3d894e8c5a9fd335f91fffb7f9.tar.gz
myautomount-5a757b0f96c60e3d894e8c5a9fd335f91fffb7f9.tar.bz2
myautomount-5a757b0f96c60e3d894e8c5a9fd335f91fffb7f9.zip
WIP: improve rpm packaging, fix desktop files
Diffstat (limited to 'myautomount.spec')
-rw-r--r--myautomount.spec38
1 files changed, 23 insertions, 15 deletions
diff --git a/myautomount.spec b/myautomount.spec
index d3e49dd..2079034 100644
--- a/myautomount.spec
+++ b/myautomount.spec
@@ -13,33 +13,38 @@
# Documentation:
# Dependencies:
-%global use_master 0
-%if !0%{?use_master}
-%global git_date 20200929
-%global git_commit 8b9bc25cc615f7e8ba86ce51d2dd83220a4e084f
+%global use_local 1
+%global use_commit 1
+%define date %(/usr/bin/date +%%Y%%m%%d)
+%if 0%{?use_commit}
+%global git_commit fc6313650f03b2c1bb097d7619478aa1fac6a39c
%{?git_commit:%global git_commit_hash %(c=%{git_commit}; echo ${c:0:7})}
%else
+%global git_commit 0.0.1
%endif
+%global releasenum 1
%define debug_package %{nil}
%global _python_bytecompile_errors_terminate_build 0
Summary: tray icon for removable media
Name: myautomount
-%if ! 0%{?use_master}
-Version: %{git_date}
-Release: 1.git%{git_commit_hash}
+%if 0%{?use_local}
+Version: %{date}
+Release: %{releasenum}
+Source: %{name}.tar.gz
%else
-Version: %( date "+%F" )
-Release: 1
+%if 0{%?use_commit}
+Version: %{date}
+Release: %{releasenum}.git%{git_commit_hash}
+%else
+Version: %{git_commit}
+Release: %{releasenum}
%endif
-License: CC BY-SA 4.0 and BSD-2-Clause
-Group: Applications/System
-%if ! 0%{?use_master}
Source: https://gitlab.com/bgstack15/%{name}/-/archive/%{git_commit}/%{name}-%{git_commit}.tar.gz
-%else
-Source: https://gitlab.com/bgstack15/%{name}/-/archive/master/%{name}-master.tar.gz
%endif
+License: CC BY-SA 4.0 and BSD-2-Clause
+Group: Applications/System
URL: https://bgstack15.wordpress.com/
Packager: B Stack <bgstack15@gmail.com>
Requires: autofs
@@ -73,9 +78,12 @@ exit 0
%postun
%files
-%config %attr(666, -, -) %{_sysconfdir}/%{name}.conf
+%config %attr(0644, -, -) %{_sysconfdir}/%{name}.conf
%{_sysconfdir}/xdg/autostart
+%config %attr(0644, -, -) %{_sysconfdir}/autofs.%{name}
+%config %attr(0644, -, -) %{_sysconfdir}/auto.master.d/*
%{_bindir}/*
+%{_datadir}/applications/*
%{_libexecdir}/%{name}/*
%doc %{_mandir}/man1/*
%doc %{_pkgdocdir}/*
bgstack15