aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-10-01 21:17:58 -0400
committerB Stack <bgstack15@gmail.com>2020-10-01 21:17:58 -0400
commit43774b5aeed25dd07c59ad9cbbe3da176b5698f8 (patch)
tree97183e5e0623d49b697f90cdfa85876ae85ec2f1 /debian/rules
parentadd todos (diff)
downloadmyautomount-43774b5aeed25dd07c59ad9cbbe3da176b5698f8.tar.gz
myautomount-43774b5aeed25dd07c59ad9cbbe3da176b5698f8.tar.bz2
myautomount-43774b5aeed25dd07c59ad9cbbe3da176b5698f8.zip
add initial dpkg recipe
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..40c9745
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@ --sourcedirectory=src
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr DEFAULTDIR='$$(DESTDIR)/etc/default'
bgstack15