aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..e7bd9e2c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+DH_VERBOSE = 1
+
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ # disable the systemd integration
+ #sed -i -e 's/shutdown -P -h now/systemctl poweroff/' src-qt5/core/libLumina/LuminaOS-Linux.cpp
+ #sed -i -e 's/shutdown -r now/systemctl reboot/' src-qt5/core/libLumina/LuminaOS-Linux.cpp
+ /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin/qmake \
+ PREFIX=/usr \
+ LIBPREFIX=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_ETCDIR=/etc \
+ QMAKE_CXXFLAGS="$(CXXFLAGS) $(CPPFLAGS)" \
+ QMAKE_LFLAGS="$(LDFLAGS) -Wl,--as-needed" \
+ CONFIG+=nostrip \
+ CONFIG+=WITH_I18N \
+ QMAKE_CFLAGS_ISYSTEM=
+
+override_dh_auto_install:
+ dh_auto_install
+ install -d debian/lumina-desktop/usr/share/icons/hicolor/64x64/apps
+ ( cd debian/lumina-desktop/usr/share/icons/hicolor ; \
+ mv scalable/apps/*.png 64x64/apps ; )
+
+override_dh_auto_clean:
+ dh_auto_clean
+ -find $(CURDIR) -name *.qm -delete
+
+override_dh_strip:
+ dh_strip --no-automatic-dbgsym
bgstack15