aboutsummaryrefslogtreecommitdiff
path: root/port-files/obsolete/debian/rules
diff options
context:
space:
mode:
authorKen Moore <ken@ixsystems.com>2019-04-27 09:29:11 -0400
committerKen Moore <ken@ixsystems.com>2019-04-27 09:29:11 -0400
commit910dd498d245e680e0bd102bc09f6499ac712cf5 (patch)
tree28da6cc2d4efb34f5528e87ca549cfbcbf8b9fe5 /port-files/obsolete/debian/rules
parentEnsure that the browser path is always canonical. (diff)
downloadlumina-910dd498d245e680e0bd102bc09f6499ac712cf5.tar.gz
lumina-910dd498d245e680e0bd102bc09f6499ac712cf5.tar.bz2
lumina-910dd498d245e680e0bd102bc09f6499ac712cf5.zip
Move the old debian/ebuild/spec port files into an obsolete directory.
If somebody wants to update them, they can get moved back into the main dir, but need to clearly mark that they are for old/obsolete versions only.
Diffstat (limited to 'port-files/obsolete/debian/rules')
-rwxr-xr-xport-files/obsolete/debian/rules45
1 files changed, 45 insertions, 0 deletions
diff --git a/port-files/obsolete/debian/rules b/port-files/obsolete/debian/rules
new file mode 100755
index 00000000..2840aa2f
--- /dev/null
+++ b/port-files/obsolete/debian/rules
@@ -0,0 +1,45 @@
+#!/usr/bin/make -f
+DH_VERBOSE = 1
+
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+#
+# you may want to comment-out --parallel if build breaks for
+# no visible reason or without meaningful error message
+#
+
+%:
+ dh $@ --parallel
+
+# For Debian GNU/Linux which does not offer manually compiled
+# libxcb-xinput0/libxcb-xinput0-dev, add the following flag:
+#
+# CONFIG+=NO_XINPUT
+#
+# also remove
+#
+# libxcb-xinput0-dev
+#
+# from dependencies in debian/rules (obviously)
+
+override_dh_auto_configure:
+ /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin/qmake \
+ PREFIX=/usr \
+ LIBPREFIX=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_ETCDIR=/etc \
+ QMAKE_CXXFLAGS="$(CXXFLAGS) $(CPPFLAGS)" \
+ QMAKE_LFLAGS="$(LDFLAGS) -Wl,--as-needed" \
+ CONFIG+=nostrip \
+ CONFIG+=WITH_I18N \
+ QMAKE_CFLAGS_ISYSTEM=
+
+override_dh_auto_clean:
+ dh_auto_clean
+ -find $(CURDIR) -name *.qm -delete
+
+override_dh_install:
+ dh_install --list-missing
bgstack15