aboutsummaryrefslogtreecommitdiff
path: root/port-files/debian/rules
diff options
context:
space:
mode:
authorKen Moore <moorekou@gmail.com>2016-06-20 11:51:28 -0400
committerKen Moore <moorekou@gmail.com>2016-06-20 11:51:28 -0400
commiteec8410951b887a2fd70798ab77366b2685dbb63 (patch)
treead2b47fd3837118f62c7931e2245886144d211a3 /port-files/debian/rules
parentOops - forgot to add a couple new .desktop files to the git repo. (diff)
downloadlumina-eec8410951b887a2fd70798ab77366b2685dbb63.tar.gz
lumina-eec8410951b887a2fd70798ab77366b2685dbb63.tar.bz2
lumina-eec8410951b887a2fd70798ab77366b2685dbb63.zip
Large update to all the port-files.
1) Move all the port files (.spec, .ebuild, debian dir, etc..) into the port-files dir. 2) Move all the FreeBSD port files into a "port-files/FreeBSD" sub-dir 3) Update all the build/install scripts (as much as possible - needs review by the porters) to account for the directory heirarchy change 4) Update the .gitignore file a bit so it is also aware of the new directory heirarchy
Diffstat (limited to 'port-files/debian/rules')
-rwxr-xr-xport-files/debian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/port-files/debian/rules b/port-files/debian/rules
new file mode 100755
index 00000000..9f19b9b5
--- /dev/null
+++ b/port-files/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+DH_VERBOSE = 1
+
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@ --parallel
+
+override_dh_auto_configure:
+ /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin/qmake \
+ PREFIX=/usr \
+ LIBPREFIX=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_ETCDIR=/etc \
+ QMAKE_CXXFLAGS="$(CXXFLAGS) $(CPPFLAGS)" \
+ QMAKE_LFLAGS="$(LDFLAGS) -Wl,--as-needed" \
+ CONFIG+=nostrip
+
+override_dh_auto_clean:
+ dh_auto_clean
+ -find $(CURDIR) -name *.qm -delete
+
+override_dh_install:
+ dh_install --list-missing
+ mv $(CURDIR)/port-files/debian/lumina-desktop/usr/bin/lumina-desktop \
+ $(CURDIR)/port-files/debian/lumina-desktop/usr/bin/lumina-desktop.real
+ install -m755 $(CURDIR)/port-files/debian/lumina-desktop \
+ $(CURDIR)/port-files/debian/lumina-desktop/usr/bin/lumina-desktop
bgstack15