aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristopher Roy Bratusek <nano@jpberlin.de>2014-09-06 22:02:01 +0200
committerChristopher Roy Bratusek <nano@jpberlin.de>2014-09-06 22:02:01 +0200
commit81ee932646662f51b5d97b6ade822a85fb257ebb (patch)
tree68360faff1caead4f77adbd7c70435979dade034 /debian/rules
parentOops, forgot to add the new OSD background image to GIT. (diff)
downloadlumina-81ee932646662f51b5d97b6ade822a85fb257ebb.tar.gz
lumina-81ee932646662f51b5d97b6ade822a85fb257ebb.tar.bz2
lumina-81ee932646662f51b5d97b6ade822a85fb257ebb.zip
debian packaging scripts
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..8d0192e4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+DH_VERBOSE = 1
+
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_auto_clean:
+ -$(MAKE) distclean
+ -find $(CURDIR) -name *.qm | xargs rm
+
+override_dh_strip:
+ dh_strip -a --dbg-package=libluminautils-dbg
+
+override_dh_auto_install:
+ INSTALL_ROOT=$(CURDIR)/debian/tmp/ $(MAKE) install
bgstack15