aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-03-11 10:45:48 -0400
committerB Stack <bgstack15@gmail.com>2020-03-11 10:45:48 -0400
commit21a2eee53ad514061b2c8d5d21ec69fec219784d (patch)
treeae6bc46355eac7d3581aacf0f69bf421d680b857 /debian/rules
parentadd usage of sudo (diff)
downloadlogout-manager-21a2eee53ad514061b2c8d5d21ec69fec219784d.tar.gz
logout-manager-21a2eee53ad514061b2c8d5d21ec69fec219784d.tar.bz2
logout-manager-21a2eee53ad514061b2c8d5d21ec69fec219784d.zip
add initial debuild stuff
move bash completion to recommended one from lint improve make deplist with SEPARATOR
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c1fee5d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+APPNAME=logout-manager
+
+%:
+ dh $@ --sourcedirectory=src
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr DEFAULTDIR='$$(DESTDIR)/etc/default'
+
+override_dh_gencontrol:
+ printf "misc:Depends=" > debian/${APPNAME}.substvars
+ make -C src deplist DISTRO=devuan SEPARATOR=',' | grep -vE 'make\[[0-9]' >> debian/${APPNAME}.substvars
+ dh_gencontrol
bgstack15