summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--scripts/prep-librewolf-dpkg.conf6
-rwxr-xr-xscripts/prep-librewolf-dpkg.sh48
2 files changed, 21 insertions, 33 deletions
diff --git a/scripts/prep-librewolf-dpkg.conf b/scripts/prep-librewolf-dpkg.conf
index 7292a69..52a284c 100644
--- a/scripts/prep-librewolf-dpkg.conf
+++ b/scripts/prep-librewolf-dpkg.conf
@@ -4,11 +4,11 @@
# Available options for DISTRO: ubuntu debian
DISTRO=${DISTRO:-'debian'}
# current version of Firefox package in target distro
-distro_firefox_version=${distro_firefox_version:-'94.0-2'}
+distro_firefox_version=${distro_firefox_version:-'95.0-1'}
# current version of Firefox, as defined by name of the orig tarball.
-firefox_version=${firefox_version:-'94.0'}
+firefox_version=${firefox_version:-'95.0'}
# Tag for LibreWolf common and linux repos
-librewolf_version=${librewolf_version:-'94.0-1'}
+librewolf_version=${librewolf_version:-'95.0-1'}
settings_commit=${settings_commit:-'master'}
CI_PROJECT_DIR=${CI_PROJECT_DIR:-$(realpath $(dirname $0)/../)}
output_dir=${CI_PROJECT_DIR}/out
diff --git a/scripts/prep-librewolf-dpkg.sh b/scripts/prep-librewolf-dpkg.sh
index c2f44ec..9859cd5 100755
--- a/scripts/prep-librewolf-dpkg.sh
+++ b/scripts/prep-librewolf-dpkg.sh
@@ -82,9 +82,9 @@ test -z "${SKIP_EXTRACT}" && {
# test -z "${SKIP_GIT}" && (
# yes, use a sub-shell because of this cd. pushd is a bash builtin, but we are using sh and not bash.
# cd "${git_source_dir}"
- git clone "${librewolf_common_url}" ${git_source_dir}/common ; ( cd "${git_source_dir}/common" ; git checkout master ; git pull ; git checkout "v${librewolf_version}" ; )
- git clone "${librewolf_settings_url}" ${git_source_dir}/settings ; ( cd "${git_source_dir}/settings" ; git checkout master ; git pull ; )
- git clone "${librewolf_linux_url}" ${git_source_dir}/linux ; ( cd "${git_source_dir}/linux" ; git checkout master ; git pull ; git checkout "v${librewolf_version}" ; )
+ git clone "${librewolf_common_url}" ${git_source_dir}/common || : ; ( cd "${git_source_dir}/common" ; git checkout master ; git pull ; git checkout "v${librewolf_version}" ; )
+ git clone "${librewolf_settings_url}" ${git_source_dir}/settings || : ; ( cd "${git_source_dir}/settings" ; git checkout master ; git pull ; )
+ git clone "${librewolf_linux_url}" ${git_source_dir}/linux || : ; ( cd "${git_source_dir}/linux" ; git checkout master ; git pull ; git checkout "v${librewolf_version}" ; )
# )
@@ -178,7 +178,6 @@ if test "${DISTRO}" = "ubuntu" ; then
"${git_source_dir}"/common/patches/sed-patches/allow-searchengines-non-esr.patch \
"${git_source_dir}"/common/patches/search-config.patch \
"${git_source_dir}"/common/patches/sed-patches/stop-undesired-requests.patch \
- "${git_source_dir}"/common/patches/allow_dark_preference_with_rfp.patch \
"${git_source_dir}"/common/patches/about-dialog.patch \
"${debian_dir}"/patches/librewolf/
cat <<EOF >> "${debian_dir}"/patches/series
@@ -193,7 +192,6 @@ librewolf/remove-internal-plugin-certs.patch -p1
librewolf/allow-searchengines-non-esr.patch -p1
#librewolf/search-config.patch -p1
librewolf/stop-undesired-requests.patch -p1
-librewolf/allow_dark_preference_with_rfp.patch -p1
librewolf/about-dialog.patch -p1
EOF
else
@@ -208,7 +206,6 @@ else
"${git_source_dir}"/common/patches/sed-patches/allow-searchengines-non-esr.patch \
"${git_source_dir}"/common/patches/search-config.patch \
"${git_source_dir}"/common/patches/sed-patches/stop-undesired-requests.patch \
- "${git_source_dir}"/common/patches/allow_dark_preference_with_rfp.patch \
"${git_source_dir}"/common/patches/about-dialog.patch \
"${git_source_dir}"/linux/deb_patches/*.patch \
"${git_source_dir}"/common/patches/mozilla_dirs.patch \
@@ -231,7 +228,6 @@ librewolf/remove-internal-plugin-certs.patch -p1
librewolf/allow-searchengines-non-esr.patch -p1
#librewolf/search-config.patch -p1
librewolf/stop-undesired-requests.patch -p1
-librewolf/allow_dark_preference_with_rfp.patch -p1
librewolf/about-dialog.patch -p1
librewolf/mozilla_dirs.patch -p1
librewolf/allow-ubo-private-mode.patch -p1
@@ -243,30 +239,22 @@ librewolf/remove-organization-policy-banner.patch -p1
librewolf/remove-snippets-from-home.patch -p1
librewolf/sanitizing-description.patch -p1
EOF
- # Fixes to the LibreWolf patches for version 94.0
- sed -i -r -e '/pictureinpicture/a\ "proxy-failover",' -e '16d' "${debian_dir}/patches/librewolf/remove_addons.patch"
- patch "${debian_dir}/patches/librewolf/pref-naming.patch" <<'EOF'
-diff --git a/patches/ui-patches/pref-naming.patch b/patches/ui-patches/pref-naming.patch
-index 6960444..6b462af 100644
---- a/patches/ui-patches/pref-naming.patch
-+++ b/patches/ui-patches/pref-naming.patch
-@@ -54,8 +54,7 @@
-
- home-prefs-search-header =
- .label = Web Search
--@@ -649,9 +649,9 @@
-- # and non-essential but also not entirely trivial and useless.
-+@@ -650,7 +650,7 @@
- home-prefs-snippets-header =
- .label = Snippets
-
-@@ -64,3 +63,4 @@
-
- home-prefs-sections-rows-option =
- .label =
-+
+ # Fixes to the LibreWolf patches for version 95.0
+ patch "${debian_dir}/patches/librewolf/remove_addons.patch" <<EOF
+diff --git a/patches/remove_addons.patch b/patches/remove_addons.patch
+index a6585ed..3487f6d 100644
+--- a/patches/remove_addons.patch
++++ b/patches/remove_addons.patch
+@@ -13,7 +13,7 @@ index 269dcb2..ed7c31d 100644
+ - "report-site-issue",
+ "pictureinpicture",
+ "proxy-failover",
+- ]
++ "search-detection",
+ diff --git a/browser/locales/Makefile.in b/browser/locales/Makefile.in
+ index 496379c..dd6f359 100644
+ --- a/browser/locales/Makefile.in
EOF
-
fi
# observe that build-with-libstdc++-7 is disabled for this dpkg. Debian builds Firefox with gcc, not clang.
bgstack15