summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2022-10-26 11:22:08 -0400
committerB. Stack <bgstack15@gmail.com>2022-10-26 11:22:08 -0400
commit64cb325840cf43424e67ca42299ceb6eb4ce1ea7 (patch)
tree034b3b944f5c31436ffeb44f98c8be5daf650be1 /scripts
parentfor 105.0, update how to fetch uBlock (diff)
downloadlibrewolf-debian-64cb325840cf43424e67ca42299ceb6eb4ce1ea7.tar.gz
librewolf-debian-64cb325840cf43424e67ca42299ceb6eb4ce1ea7.tar.bz2
librewolf-debian-64cb325840cf43424e67ca42299ceb6eb4ce1ea7.zip
prep 106.0
Diffstat (limited to 'scripts')
-rw-r--r--scripts/prep-librewolf-dpkg.conf6
-rwxr-xr-xscripts/prep-librewolf-dpkg.sh197
2 files changed, 145 insertions, 58 deletions
diff --git a/scripts/prep-librewolf-dpkg.conf b/scripts/prep-librewolf-dpkg.conf
index 737d803..768b5a4 100644
--- a/scripts/prep-librewolf-dpkg.conf
+++ b/scripts/prep-librewolf-dpkg.conf
@@ -4,11 +4,11 @@
# Available options for DISTRO: debian
DISTRO=${DISTRO:-'debian'}
# current version of Firefox package in target distro
-distro_firefox_version=${distro_firefox_version:-'105.0-1'}
+distro_firefox_version=${distro_firefox_version:-'106.0-1'}
# current version of Firefox, as defined by name of the orig tarball.
-firefox_version=${firefox_version:-'105.0'}
+firefox_version=${firefox_version:-'106.0'}
# Tag for LibreWolf linux repo
-librewolf_version=${librewolf_version:-'105.0.1-1'}
+librewolf_version=${librewolf_version:-'106.0.1-1'}
settings_commit=${settings_commit:-'master'}
CI_PROJECT_DIR=${CI_PROJECT_DIR:-$(realpath $(dirname $0)/../)}
output_dir=${CI_PROJECT_DIR}/out
diff --git a/scripts/prep-librewolf-dpkg.sh b/scripts/prep-librewolf-dpkg.sh
index 4cdd64c..a7f1a73 100755
--- a/scripts/prep-librewolf-dpkg.sh
+++ b/scripts/prep-librewolf-dpkg.sh
@@ -199,6 +199,148 @@ else
awk -F'/' '{print "librewolf/"$NF}' "${git_source_dir}"/source/assets/patches.txt | \
sed -r -e 's@$@ -p1@' -e '/vpn-ad/d' >> "${debian_dir}/patches/series"
#echo "librewolf/webrender_ffi.patch -p1" >> "${debian_dir}/patches/series"
+ # added 106.0.1 to patch for debian 106.0 until defuzz-106.0.1 gets merged
+ test -n "1" && patch -p1 "${debian_dir}/patches/librewolf/website-appearance-ui-rfp.patch" <<EOF
+diff --git a/patches/ui-patches/website-appearance-ui-rfp.patch b/patches/ui-patches/website-appearance-ui-rfp.patch
+index 0de5504..7915e9c 100644
+--- a/patches/ui-patches/website-appearance-ui-rfp.patch
++++ b/patches/ui-patches/website-appearance-ui-rfp.patch
+@@ -1,22 +1,22 @@
+ --- a/browser/components/preferences/main.js
+ +++ b/browser/components/preferences/main.js
+-@@ -3737,6 +3737,7 @@ const AppearanceChooser = {
++@@ -3717,6 +3717,7 @@ const AppearanceChooser = {
++
+ FORCED_COLORS_QUERY.addEventListener("change", this);
+- SYSTEM_DARK_MODE_QUERY.addEventListener("change", this);
+ Services.prefs.addObserver(PREF_USE_SYSTEM_COLORS, this);
+ + Services.prefs.addObserver("privacy.resistFingerprinting", this);
+ Services.obs.addObserver(this, "look-and-feel-changed");
+ this._update();
+ },
+-@@ -3756,6 +3757,7 @@ const AppearanceChooser = {
++@@ -3736,6 +3737,7 @@ const AppearanceChooser = {
+
+ destroy() {
+ Services.prefs.removeObserver(PREF_USE_SYSTEM_COLORS, this);
+ + Services.prefs.removeObserver("privacy.resistFingerprinting", this);
+ Services.obs.removeObserver(this, "look-and-feel-changed");
+ FORCED_COLORS_QUERY.removeEventListener("change", this);
+- SYSTEM_DARK_MODE_QUERY.removeEventListener("change", this);
+-@@ -3798,5 +3800,33 @@ const AppearanceChooser = {
++ },
++@@ -3775,5 +3777,33 @@ const AppearanceChooser = {
+ (AppConstants.platform == "win" ||
+ !Services.prefs.getBoolPref(PREF_USE_SYSTEM_COLORS));
+ this.warning.hidden = !forcingColorsAndNoColorSchemeSupport;
+EOF
+ # added 106.0.1 to patch for debian 106.0 until defuzz-106.0.1 gets merged
+ test -n "1" && patch -p1 "${debian_dir}/patches/librewolf/firefox-view.patch" <<EOF
+diff --git a/patches/ui-patches/firefox-view.patch b/patches/ui-patches/firefox-view.patch
+index ea0e580..ee089ac 100644
+--- a/patches/ui-patches/firefox-view.patch
++++ b/patches/ui-patches/firefox-view.patch
+@@ -1,7 +1,6 @@
+-diff --git a/browser/app/profile/firefox.js b/browser/app/profile/firefox.js
+ --- a/browser/app/profile/firefox.js
+ +++ b/browser/app/profile/firefox.js
+-@@ -777,6 +777,9 @@ pref("browser.tabs.tooltipsShowPidAndAct
++@@ -776,6 +776,9 @@ pref("browser.tabs.tooltipsShowPidAndAct
+ pref("browser.tabs.firefox-view", true);
+ pref("browser.tabs.firefox-view.logLevel", "Warn");
+
+@@ -11,10 +10,9 @@ diff --git a/browser/app/profile/firefox.js b/browser/app/profile/firefox.js
+ // allow_eval_* is enabled on Firefox Desktop only at this
+ // point in time
+ pref("security.allow_eval_with_system_principal", false);
+-diff --git a/browser/components/customizableui/CustomizableUI.jsm b/browser/components/customizableui/CustomizableUI.jsm
+ --- a/browser/components/customizableui/CustomizableUI.jsm
+ +++ b/browser/components/customizableui/CustomizableUI.jsm
+-@@ -277,7 +277,6 @@ var CustomizableUIInternal = {
++@@ -274,7 +274,6 @@ var CustomizableUIInternal = {
+ {
+ type: CustomizableUI.TYPE_TOOLBAR,
+ defaultPlacements: [
+@@ -22,7 +20,7 @@ diff --git a/browser/components/customizableui/CustomizableUI.jsm b/browser/comp
+ "tabbrowser-tabs",
+ "new-tab-button",
+ "alltabs-button",
+-@@ -605,18 +604,6 @@ var CustomizableUIInternal = {
++@@ -602,18 +601,6 @@ var CustomizableUIInternal = {
+ navbarPlacements.splice(newPosition, 0, "save-to-pocket-button");
+ }
+ }
+@@ -41,7 +39,6 @@ diff --git a/browser/components/customizableui/CustomizableUI.jsm b/browser/comp
+ },
+
+ _updateForNewProtonVersion() {
+-diff --git a/browser/components/firefoxview/firefoxview.html b/browser/components/firefoxview/firefoxview.html
+ --- a/browser/components/firefoxview/firefoxview.html
+ +++ b/browser/components/firefoxview/firefoxview.html
+ @@ -113,7 +113,7 @@
+@@ -62,12 +59,11 @@ diff --git a/browser/components/firefoxview/firefoxview.html b/browser/component
+ <template id="colorways-no-collection-template">
+ <div class="content-container">
+ <div id="no-current-colorway-collection-notice" data-l10n-id="firefoxview-no-current-colorway-collection"></div>
+-diff --git a/browser/components/firefoxview/firefoxview.mjs b/browser/components/firefoxview/firefoxview.mjs
+ --- a/browser/components/firefoxview/firefoxview.mjs
+ +++ b/browser/components/firefoxview/firefoxview.mjs
+-@@ -28,7 +28,26 @@ const MediaQueryDOMSorting = {
+- },
+- };
++@@ -4,7 +4,26 @@
++
++ "use strict";
+
+ +function onPrefChange() {
+ + document.getElementById("tab-pickup-container").hidden =
+EOF
+ # added 106.0.1 to patch for debian 106.0 until defuzz-106.0.1 gets merged
+ test -n "1" && patch -p1 "${debian_dir}/patches/librewolf/disable-pocket.patch" <<EOF
+diff --git a/patches/sed-patches/disable-pocket.patch b/patches/sed-patches/disable-pocket.patch
+index 25e4056..c2f5182 100644
+--- a/patches/sed-patches/disable-pocket.patch
++++ b/patches/sed-patches/disable-pocket.patch
+@@ -1,8 +1,6 @@
+-diff --git a/browser/base/content/browser.js b/browser/base/content/browser.js
+-index f59f732..07a9a60 100644
+ --- a/browser/base/content/browser.js
+ +++ b/browser/base/content/browser.js
+-@@ -5445,8 +5445,6 @@ var XULBrowserWindow = {
++@@ -5466,8 +5466,6 @@ var XULBrowserWindow = {
+
+ SafeBrowsingNotificationBox.onLocationChange(aLocationURI);
+
+@@ -11,11 +9,9 @@ index f59f732..07a9a60 100644
+ UrlbarProviderSearchTips.onLocationChange(
+ window,
+ aLocationURI,
+-diff --git a/browser/components/BrowserGlue.jsm b/browser/components/BrowserGlue.jsm
+-index 64ac529..8cf69c1 100644
+ --- a/browser/components/BrowserGlue.jsm
+ +++ b/browser/components/BrowserGlue.jsm
+-@@ -1269,7 +1269,6 @@ BrowserGlue.prototype = {
++@@ -1286,7 +1286,6 @@ BrowserGlue.prototype = {
+ lazy.Normandy.init();
+ }
+
+@@ -23,13 +19,11 @@ index 64ac529..8cf69c1 100644
+
+ AboutHomeStartupCache.init();
+
+-diff --git a/browser/components/moz.build b/browser/components/moz.build
+-index 71a1b85..ed3b6d1 100644
+ --- a/browser/components/moz.build
+ +++ b/browser/components/moz.build
+-@@ -42,7 +42,6 @@ DIRS += [
++@@ -44,7 +44,6 @@ DIRS += [
+ "originattributes",
+- "ion",
++ "pagedata",
+ "places",
+ - "pocket",
+ "preferences",
+EOF
# added 103.0
test -n "1" && patch -p1 "${debian_dir}/patches/librewolf/remove-snippets-from-home.patch" <<EOF
--- ../../git/source/patches/ui-patches/remove-snippets-from-home.patch 2022-03-22 19:01:35.323802032 -0400
@@ -225,23 +367,6 @@ EOF
# ref: https://gitlab.com/librewolf-community/browser/gentoo/-/issues/42#note_985094574
# ref: https://forums.gentoo.org/viewtopic-p-8718512.html?sid=b090546e8d9bcd60ff775c32d04e1743
# ref: https://www.google.com/search?hl=en&q=build%2Dbrowser%2Fdist%2Finclude%2Fmozilla%2Fwebrender%2Fwebrender_ffi.h%3A103
- test -n "" && cat <<EOF >"${debian_dir}/patches/librewolf/webrender_ffi.patch"
-Description: Remove an extra constant definition that is now being generated by newer versions of cbindgen (0.24), and causing build failures because it is defined in several places.
-Author: Olivier Tilloy <olivier.tilloy@canonical.com>
-Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1773259
-Forwarded: not-needed
-
---- a/gfx/webrender_bindings/webrender_ffi.h
-+++ b/gfx/webrender_bindings/webrender_ffi.h
-@@ -73,8 +73,6 @@ struct WrPipelineInfo;
- struct WrPipelineIdAndEpoch;
- using WrPipelineIdEpochs = nsTArray<WrPipelineIdAndEpoch>;
-
--const uint64_t ROOT_CLIP_CHAIN = ~0;
--
- } // namespace wr
- } // namespace mozilla
-EOF
# For 100.0 to fix this patch.
test -n "1" && cat <<EOF >"${debian_dir}/patches/librewolf/remove-branding-urlbar.patch"
--- a/browser/locales/en-US/browser/browser.ftl.orig 2022-03-22 12:57:21.330016999 -0400
@@ -256,46 +381,8 @@ EOF
# A label shown above the search suggestions group in the urlbar results. It
# should use sentence case.
EOF
- test -n "" && patch -p1 "${debian_dir}/patches/librewolf/remove-organization-policy-banner.patch" <<EOF
-diff --git a/patches/ui-patches/remove-organization-policy-banner.patch b/patches/ui-patches/remove-organization-policy-banner.patch
-index 688c17c..1475de9 100644
---- a/patches/ui-patches/remove-organization-policy-banner.patch
-+++ b/patches/ui-patches/remove-organization-policy-banner.patch
-@@ -1,6 +1,6 @@
- --- a/browser/components/preferences/preferences.js
- +++ b/browser/components/preferences/preferences.js
--@@ -161,8 +161,6 @@
-+@@ -234,8 +234,6 @@
- this.removeAttribute("keyboard-navigation");
- });
-
-@@ -8,4 +8,4 @@
- -
- window.addEventListener("hashchange", onHashChange);
-
-- gotoPref().then(() => {
-+ document.getElementById("focusSearch1").addEventListener("command", () => {
-EOF
# remove xmas because it does the same tasks as what we accomplish in this script,
sed -i -r -e '/(xmas)\.patch/s/^/#/;' "${debian_dir}"/patches/series
- # Fixes to the LibreWolf patches for version 96.0.1.
- # remove_addons.patch will be fixed when https://gitlab.com/librewolf-community/browser/source/-/merge_requests/10
- test -n "" && patch -p1 "${debian_dir}/patches/librewolf/remove_addons.patch" <<EOF
-diff --git a/patches/remove_addons.patch b/patches/remove_addons.patch
-index a6585ed..3487f6d 100644
---- a/patches/remove_addons.patch
-+++ b/patches/remove_addons.patch
-@@ -12,8 +12,8 @@
- "webcompat",
- - "report-site-issue",
- "pictureinpicture",
-- "proxy-failover",
- "search-detection",
-+ ]
- diff --git a/browser/locales/Makefile.in b/browser/locales/Makefile.in
- index 496379c..dd6f359 100644
- --- a/browser/locales/Makefile.in
-EOF
# Fixes for Debian Firefox? 97.0
pip3 install --user psutil==5.8.0
bgstack15