aboutsummaryrefslogtreecommitdiff
path: root/icons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'icons/Makefile.am')
-rw-r--r--icons/Makefile.am21
1 files changed, 12 insertions, 9 deletions
diff --git a/icons/Makefile.am b/icons/Makefile.am
index e2e3987..9c08390 100644
--- a/icons/Makefile.am
+++ b/icons/Makefile.am
@@ -1,11 +1,14 @@
-NULL =
+SUBDIRS = 22x22 48x48 scalable
-smallicondir=${pkgdatadir}/icons/hicolor/22x22/apps
-smallicon_DATA= \
- krb-valid-ticket.png \
- krb-no-valid-ticket.png \
- krb-expiring-ticket.png \
- $(NULL)
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-EXTRA_DIST=\
- $(smallicon_DATA)
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
bgstack15