aboutsummaryrefslogtreecommitdiff
path: root/etpo/Makefile.am
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2009-05-25 18:39:27 +0200
committerGuido Günther <agx@sigxcpu.org>2009-05-25 18:39:27 +0200
commitd911517dc2f9c4c3ce57529ac4d64c17185544e9 (patch)
treeb4f7a09a3cf84ac25b3cabdcf74fb448ef82eb53 /etpo/Makefile.am
parentImported Upstream version 0.9.1 (diff)
downloadkrb5-auth-dialog-d911517dc2f9c4c3ce57529ac4d64c17185544e9.tar.gz
krb5-auth-dialog-d911517dc2f9c4c3ce57529ac4d64c17185544e9.tar.bz2
krb5-auth-dialog-d911517dc2f9c4c3ce57529ac4d64c17185544e9.zip
Imported Upstream version 0.10
Diffstat (limited to 'etpo/Makefile.am')
-rw-r--r--etpo/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/etpo/Makefile.am b/etpo/Makefile.am
index 632ec22..2a92ecd 100644
--- a/etpo/Makefile.am
+++ b/etpo/Makefile.am
@@ -4,7 +4,6 @@ lexer.c: grammar.h
AM_YFLAGS=-d
AM_CFLAGS=\
@GTK_CFLAGS@ \
- @GLADE_CFLAGS@ \
@DBUS_CFLAGS@ \
@GCONF_CFLAGS@ \
@KRB5_CFLAGS@ \
@@ -17,8 +16,22 @@ AM_LDFLAGS=\
@LIBNOTIFY_LIBS@ \
@DBUS_LIBS@ \
@GCONF_LIBS@ \
- @GLADE_LIBS@ \
@GTK_LIBS@
DISTCLEANFILES=lexer.c
+# rebuild dummy strings for translation from Kerberos sources
+ET_SUBDIR="src/lib/krb5/"
+# ignore these to reduce translatable strings
+ET_IGNORE="(kdb5_err|krb524|KRB5PLACEHOLD)"
+
+update-etpo: ${top_srcdir}/src/dummy-strings.c
+
+${top_srcdir}/src/dummy-strings.c: etpo
+ @if [ -z "${ET_DIR}" ]; then \
+ echo "Need to set ET_DIR to Kerberos sources"; \
+ exit 1; \
+ fi
+ echo '/* Generated by hand via "cd etpo; make update-etpo" from ${ET_DIR} */' > $@.tmp
+ ./$< ${ET_DIR}${ET_SUBDIR} | egrep -v ${ET_IGNORE} >> $@.tmp
+ mv -f $@.tmp $@
bgstack15