aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2024-05-04 09:45:07 -0400
committerB. Stack <bgstack15@gmail.com>2024-05-04 09:45:07 -0400
commitbe1a9d87f6129cd2d270ab0466b9ea5d39405288 (patch)
tree76a7e0f31cab533a232d053c724f6fb0705eb9cf /debian
parentDocument changes and release 3.26.1-4 (diff)
downloadkrb5-auth-dialog-be1a9d87f6129cd2d270ab0466b9ea5d39405288.tar.gz
krb5-auth-dialog-be1a9d87f6129cd2d270ab0466b9ea5d39405288.tar.bz2
krb5-auth-dialog-be1a9d87f6129cd2d270ab0466b9ea5d39405288.zip
fix compile problems on Devuan
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control6
-rw-r--r--debian/krb5-auth-dialog.lintian-overrides2
-rw-r--r--debian/patches/fix-compile.patch67
-rw-r--r--debian/patches/series1
5 files changed, 85 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 4b1afc5..cbceffd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+krb5-auth-dialog (1:3.26.1-4+stackrpms) unstable; urgency=medium
+
+ * Rebuild with epoch for stackrpms
+
+ -- B. Stack <bgstack15@gmail.com> Sat, 04 May 2024 09:43:46 -0400
+
+krb5-auth-dialog (3.26.0-1) unstable; urgency=medium
+
+ * Dummy entry for lintian
+
+ -- B. Stack <bgstack15@gmail.com> Sat, 04 May 2024 08:24:36 -0400
+
krb5-auth-dialog (3.26.1-4) unstable; urgency=medium
* Drop dependency on libglade2-dev - unused since ages. (Closes: #967872)
diff --git a/debian/control b/debian/control
index 64456fe..e5b5598 100644
--- a/debian/control
+++ b/debian/control
@@ -1,7 +1,7 @@
Source: krb5-auth-dialog
Section: gnome
Priority: optional
-Maintainer: Guido Günther <agx@sigxcpu.org>
+Maintainer: B. Stack <bgstack15@gmail.com>
Build-Depends:
autoconf,
automake,
@@ -9,7 +9,7 @@ Build-Depends:
cdbs,
debhelper (>= 10),
flex,
- gnome-common,
+#gnome-common,
intltool,
itstool,
libglib2.0-dev (>= 2.26.0),
@@ -18,7 +18,7 @@ Build-Depends:
libnm-dev,
libnotify-dev (>= 0.7.1),
libpam0g-dev,
- pkg-config,
+ pkgconf,
yelp-tools,
Standards-Version: 4.1.3
Vcs-Git: https://salsa.debian.org/agx/krb5-auth-dialog.git
diff --git a/debian/krb5-auth-dialog.lintian-overrides b/debian/krb5-auth-dialog.lintian-overrides
new file mode 100644
index 0000000..3b674e1
--- /dev/null
+++ b/debian/krb5-auth-dialog.lintian-overrides
@@ -0,0 +1,2 @@
+krb5-auth-dialog: library-not-linked-against-libc [usr/lib/*/krb5-auth-dialog/plugins/libka-plugin-dummy.so]
+krb5-auth-dialog: shared-library-lacks-prerequisites [usr/lib/krb5-auth-dialog/plugins/libka-plugin-dummy.so]
diff --git a/debian/patches/fix-compile.patch b/debian/patches/fix-compile.patch
new file mode 100644
index 0000000..4ffa97d
--- /dev/null
+++ b/debian/patches/fix-compile.patch
@@ -0,0 +1,67 @@
+--- a/etpo/lexer.l
++++ b/etpo/lexer.l
+@@ -62,6 +62,8 @@ error_code|ec { yylval.sval = g_strdup(
+ static GList *filenames = NULL, *filename = NULL;
+ const char *currentfile = NULL;
+
++int yyerror(void);
++
+ int
+ yyerror(void)
+ {
+--- a/etpo/grammar.h
++++ b/etpo/grammar.h
+@@ -40,6 +40,8 @@
+ extern int yydebug;
+ #endif
+
++extern int yylex (void);
++
+ /* Token type. */
+ #ifndef YYTOKENTYPE
+ # define YYTOKENTYPE
+--- a/etpo/grammar.c
++++ b/etpo/grammar.c
+@@ -88,6 +88,9 @@
+ static const char *table = "unknown";
+ extern const char *currentfile;
+
++extern int yylex(void);
++extern int yyerror();
++
+ #line 92 "grammar.c" /* yacc.c:339 */
+
+ # ifndef YY_NULLPTR
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -26,7 +26,7 @@ $(service_DATA): $(service_in_files) Mak
+ sed -e "s|\@BINDIR\@|$(bindir)|" $< > $@
+
+ @INTLTOOL_XML_RULE@
+-appdatadir = $(datadir)/appdata
++appdatadir = $(datadir)/metainfo
+ appdata_in_files = krb5-auth-dialog.appdata.xml.in
+ appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -434,7 +434,7 @@ dist_convert_DATA = org.gnome.KrbAuthDia
+ servicedir = $(datadir)/dbus-1/services
+ service_in_files = org.gnome.KrbAuthDialog.service.in
+ service_DATA = $(service_in_files:.service.in=.service)
+-appdatadir = $(datadir)/appdata
++appdatadir = $(datadir)/metainfo
+ appdata_in_files = krb5-auth-dialog.appdata.xml.in
+ appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+ krb5_auth_dialog_SOURCES = \
+--- a/src/krb5-auth-dialog.1.in
++++ b/src/krb5-auth-dialog.1.in
+@@ -17,7 +17,7 @@ credentials, prompting the user for what
+
+ .TP
+ \fB--auto\fR
+-If this option is specified, \fkrb5-auth-dialog\f will start only if it
++If this option is specified, \fBkrb5-auth-dialog\fR will start only if it
+ finds that the user has Kerberos credentials. This may be used to
+ ensure that only users who actually use Kerberos see the program.
+ Note that in some settings, users may authenticate to Kerberos at a
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ae688c9
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+fix-compile.patch
bgstack15