aboutsummaryrefslogtreecommitdiff
path: root/rpm/jellyfin.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rpm/jellyfin.spec')
-rw-r--r--rpm/jellyfin.spec21
1 files changed, 11 insertions, 10 deletions
diff --git a/rpm/jellyfin.spec b/rpm/jellyfin.spec
index 2f14f7e..347cc39 100644
--- a/rpm/jellyfin.spec
+++ b/rpm/jellyfin.spec
@@ -24,6 +24,7 @@ License: GPL-2.0-only
URL: https://jellyfin.org
Source0: https://github.com/jellyfin/jellyfin/archive/v%{version}/%{name}-%{version}.tar.gz
Source1: https://github.com/jellyfin/jellyfin-web/archive/v%{version}/%{name}-web-%{version}.tar.gz
+# FIXME: these nupkg ones probably come from the `dotnet restore` list.
Source2: %{name}-nupkgs.tar.xz
Source3: %{name}-nupkgs2.tar.xz
Source4: %{name}-npm.tar.xz
@@ -118,17 +119,17 @@ The Jellyfin media server web frontend.
%prep
%autosetup -p1 -b 1 -n jellyfin-server
pushd ..
-tar xf %{SOURCE2}
-tar xf %{SOURCE3}
-tar xf %{SOURCE4}
-cp -p %{SOURCE5} %{name}-web-%{version}/package-lock.json
+#tar xf %%{SOURCE2}
+#tar xf %%{SOURCE3}
+#tar xf %%{SOURCE4}
+cp -p %{SOURCE5} %{name}-web/package-lock.json
popd
-dotnet nuget add source %{_builddir}/jellyfin-nupkgs -n jellyfin-nupkgs
-dotnet nuget add source %{_builddir}/jellyfin-nupkgs2 -n jellyfin-nupkgs2
-dotnet nuget disable source nuget.org
-dotnet nuget disable source "NuGet official package source"
+#dotnet nuget add source %{_builddir}/jellyfin-nupkgs -n jellyfin-nupkgs
+#dotnet nuget add source %{_builddir}/jellyfin-nupkgs2 -n jellyfin-nupkgs2
+#dotnet nuget disable source nuget.org
+#dotnet nuget disable source "NuGet official package source"
%build
@@ -141,7 +142,7 @@ dotnet publish --configuration Release \
--runtime %{dotnet_rid} \
"-p:DebugSymbols=false;DebugType=none" \
Jellyfin.Server
-cd ../%{name}-web-%{version}
+cd ../%{name}-web
npm config set offline=true
npm config set cache ../jellyfin-npm
npm ci
@@ -181,7 +182,7 @@ mkdir -p %{buildroot}%{_localstatedir}/log/jellyfin
# jellyfin-server-lowports subpackage
install -p -m 644 -D %{SOURCE17} %{buildroot}%{_unitdir}/jellyfin.service.d/jellyfin-server-lowports.conf
-cd ../%{name}-web-%{version}
+cd ../%{name}-web
# move web licenses prior to installation
mv dist/*.js.LICENSE.txt ../jellyfin-%{version}/
mv dist/libraries/*.js.LICENSE.txt ../jellyfin-%{version}/
bgstack15