aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJoshua M. Boniface <joshua@boniface.me>2024-02-04 16:42:36 -0500
committerJoshua M. Boniface <joshua@boniface.me>2024-02-07 02:26:43 -0500
commit7666f4d8b4d163d4830a82cce7db7849ae196581 (patch)
tree860f879715fefa5d952283e97e0e6184bfcf5718 /debian/rules
parentAdd missing step to README (diff)
downloadjellyfin-packaging-7666f4d8b4d163d4830a82cce7db7849ae196581.tar.gz
jellyfin-packaging-7666f4d8b4d163d4830a82cce7db7849ae196581.tar.bz2
jellyfin-packaging-7666f4d8b4d163d4830a82cce7db7849ae196581.zip
Add Dockerized debian builders
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 8c52b29..678c4d8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,6 +28,8 @@ endif
export DH_VERBOSE=1
export DOTNET_CLI_TELEMETRY_OPTOUT=1
+export COMPlus_LTTng=0
+export COMPlus_EnableDiagnostics=0
%:
dh $@
@@ -40,11 +42,13 @@ override_dh_auto_build:
cd jellyfin-server && dotnet publish -maxcpucount:1 --configuration $(CONFIG) \
--output='$(CURDIR)/build/usr/lib/jellyfin/bin' --self-contained --runtime $(DOTNETRUNTIME) \
-p:DebugSymbols=false -p:DebugType=none Jellyfin.Server
+ rm $(CURDIR)/build/usr/lib/jellyfin/bin/libcoreclrtraceptprovider.so
cd jellyfin-web && npm ci --no-audit --unsafe-perm && \
npm run build:production && mv $(CURDIR)/jellyfin-web/dist $(CURDIR)/build/web
override_dh_auto_clean:
cd jellyfin-server && dotnet clean -maxcpucount:1 --configuration $(CONFIG) Jellyfin.Server || true
+ cd jellyfin-server && find . -type d \( -name bin -o -name obj \) -exec rm -r {} \; || true
test -d $(CURDIR)/jellyfin-web/dist && \
rm -rf '$(CURDIR)/jellyfin-web/dist' || true
test -d $(CURDIR)/jellyfin-web/web && \
@@ -55,3 +59,6 @@ override_dh_auto_clean:
override_dh_installinit:
dh_installinit --name=jellyfin
+
+override_dh_shdeplibs:
+ dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
bgstack15