aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorUruk <uruknarb20@gmail.com>2024-02-23 17:52:10 +0100
committerUruk <uruknarb20@gmail.com>2024-02-23 17:52:10 +0100
commit104f91e697d8c5c4bb71ce995c2b95ab75d84dae (patch)
tree28c41531064d78e3364c30c88b4ed368d2560ed1 /debian/rules
parentUpdate repository script to use BASEDIR (diff)
downloadjellyfin-packaging-104f91e697d8c5c4bb71ce995c2b95ab75d84dae.tar.gz
jellyfin-packaging-104f91e697d8c5c4bb71ce995c2b95ab75d84dae.tar.bz2
jellyfin-packaging-104f91e697d8c5c4bb71ce995c2b95ab75d84dae.zip
Refactor jellyfin-packaging
- Fix typo in the README - Added -f to rm from fix https://github.com/jellyfin/jellyfin/pull/11008 - Apply fix from https://github.com/jellyfin/jellyfin/pull/10763 - Refactor Docker for better syntax and readability - Update Intel runtime drivers to 24.05.28454.6 - Added possible miss line 159 docker/Dockerfile : "--ffmpeg", "/usr/lib/jellyfin-ffmpeg/ffmpeg" - Removed wget in cleanup
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 678c4d8..e8a07bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,7 +42,7 @@ override_dh_auto_build:
cd jellyfin-server && dotnet publish -maxcpucount:1 --configuration $(CONFIG) \
--output='$(CURDIR)/build/usr/lib/jellyfin/bin' --self-contained --runtime $(DOTNETRUNTIME) \
-p:DebugSymbols=false -p:DebugType=none Jellyfin.Server
- rm $(CURDIR)/build/usr/lib/jellyfin/bin/libcoreclrtraceptprovider.so
+ rm -f $(CURDIR)/build/usr/lib/jellyfin/bin/libcoreclrtraceptprovider.so
cd jellyfin-web && npm ci --no-audit --unsafe-perm && \
npm run build:production && mv $(CURDIR)/jellyfin-web/dist $(CURDIR)/build/web
bgstack15