aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2023-07-13 09:56:51 -0400
committerB. Stack <bgstack15@gmail.com>2023-07-13 09:56:51 -0400
commit3fcd32aa6d295ac62fe0e526931fc556a4060343 (patch)
tree244c95a3ed1cf21c4cb2705276062d98cd7e10ae /debian/rules
downloadfix-alttab-3fcd32aa6d295ac62fe0e526931fc556a4060343.tar.gz
fix-alttab-3fcd32aa6d295ac62fe0e526931fc556a4060343.tar.bz2
fix-alttab-3fcd32aa6d295ac62fe0e526931fc556a4060343.zip
initial commit
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9d50627
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export APPNAME=fix-alttab
+
+%:
+ dh $@ --sourcedirectory=src
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr DEFAULTDIR='$$(DESTDIR)/etc/default'
+
+override_dh_auto_build:
+ dh_auto_build
+ make-dsc-for-obs
bgstack15