summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDmitry Smirnov <onlyjob@member.fsf.org>2013-08-04 05:49:48 +1000
committerDmitry Smirnov <onlyjob@member.fsf.org>2013-08-04 05:49:48 +1000
commitf5563d8240be0b355c53588139b9d1674676c691 (patch)
treee4d9c0a8c6a42762aa2e703c28f16aa9abeb6d2a /debian/rules
parentreference get-orig-source implementation (diff)
downloadd2x-rebirth-f5563d8240be0b355c53588139b9d1674676c691.tar.gz
d2x-rebirth-f5563d8240be0b355c53588139b9d1674676c691.tar.bz2
d2x-rebirth-f5563d8240be0b355c53588139b9d1674676c691.zip
New upstream release [0.58.1] + changelog summarydebian/0.58.1-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 1 insertions, 13 deletions
diff --git a/debian/rules b/debian/rules
index fd15757..0adb695 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,7 +43,7 @@ override_dh_builddeb:
PKD = $(abspath $(dir $(MAKEFILE_LIST)))
PKG = $(word 2,$(shell dpkg-parsechangelog -l$(PKD)/changelog | grep ^Source))
VER ?= $(shell dpkg-parsechangelog -l$(PKD)/changelog | perl -ne 'print $$1 if m{Version:\s*([\d\.]+)}')
-DTYPE = +repack
+DTYPE =
.PHONY: get-orig-source
get-orig-source: $(PKG)_$(VER)$(DTYPE).orig.tar.xz
@
@@ -51,15 +51,3 @@ get-orig-source: $(PKG)_$(VER)$(DTYPE).orig.tar.xz
$(PKG)_$(VER)$(DTYPE).orig.tar.xz:
@echo "# Downloading..."
uscan --noconf --verbose --rename --destdir=$(CURDIR) --check-dirname-level=0 --force-download --download-version $(VER) $(PKD)
- $(if $(wildcard $(PKG)-$(VER)),$(error $(PKG)-$(VER) exist, aborting..))
- @echo "# Extracting..."
- mkdir $(PKG)-$(VER) \
- && tar -xf $(PKG)_$(VER).orig.tar.* --directory $(PKG)-$(VER) --strip-components 1 \
- || $(RM) -r $(PKG)-$(VER)
- @echo "# Clean-up..."
- cd $(PKG)-$(VER) \
- && $(RM) -r -v \
- include/psmacros.inc
- @echo "# Packing..."
- XZ_OPT="-6v" tar -caf "$(PKG)_$(VER)$(DTYPE).orig.tar.xz" "$(PKG)-$(VER)" \
- && $(RM) -r "$(PKG)-$(VER)"
bgstack15