summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorB. Stack <bgstack15@gmail.com>2023-09-16 19:23:35 -0400
committerB. Stack <bgstack15@gmail.com>2023-09-16 19:23:35 -0400
commit9dc557ebd6b305bb4d4146dc77b499f7288fa37c (patch)
tree5c6913f0b0c9a327131aeee52fbfc0dfa8f3d0de /debian/rules
parentbringing in updates to the package since then (diff)
downloadd2x-rebirth-9dc557ebd6b305bb4d4146dc77b499f7288fa37c.tar.gz
d2x-rebirth-9dc557ebd6b305bb4d4146dc77b499f7288fa37c.tar.bz2
d2x-rebirth-9dc557ebd6b305bb4d4146dc77b499f7288fa37c.zip
update packaging for building now
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 01ce32c..aaff96e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,9 +2,10 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+export SUBDIR=d2x-rebirth
%:
- dh $@ --parallel
+ dh $@ --parallel --sourcedirectory="${SUBDIR}"
override_dh_clean:
scons --clean
@@ -13,7 +14,7 @@ override_dh_clean:
override_dh_auto_build:
dh_auto_build
## build menu icon
- convert d2x-rebirth.xpm -resize 32x32 debian/d2x-rebirth32.xpm
+ convert "${SUBDIR}"/d2x-rebirth.xpm -resize 32x32 debian/d2x-rebirth32.xpm
CFLAGS="$(CFLAGS) $(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" \
scons prefix=/usr verbosebuild=1 --debug=presub
@@ -34,7 +35,7 @@ override_dh_auto_install:
dh_auto_install --destdir=$(CURDIR)/tmp
override_dh_installchangelogs:
- dh_installchangelogs CHANGELOG.txt
+ dh_installchangelogs "${SUBDIR}"/CHANGELOG.txt
## http://wiki.debian.org/onlyjob/get-orig-source
PKD = $(abspath $(dir $(MAKEFILE_LIST)))
bgstack15