aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index bc6662c..2d1d47a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,15 +10,22 @@ export buildroot="${debuilddir}/${appname}"
export _datadir="/usr/share"
export _bindir="/usr/bin"
+# if dhcompat=13 then the .install file can use ${Space} but we are at dhcompat=9
+# so we have to use underscores for the make install.
+export use_underscores=YES
+
%:
dh $@
override_dh_auto_install:
dh_auto_install
-
install -m0755 -d ${buildroot}${_datadir}/sounds/Chicago95
install -m0644 "Extras/Microsoft Windows 95 Startup Sound.ogg" ${buildroot}${_datadir}/sounds/Chicago95/startup.ogg
override_dh_auto_clean:
rm -f ${buildroot}${_datadir}/sounds/Chicago95/startup.ogg
dh_auto_clean
+
+override_dh_fixperms:
+ dh_fixperms || :
+ chmod 0755 ${buildroot}${_datadir}/themes/Chicago95/gtk-3.0 || :
bgstack15