aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rw-r--r--debian/chicago95-theme-doc.install2
-rw-r--r--debian/chicago95-theme-gtk.install1
-rw-r--r--debian/chicago95-theme-plus.install2
-rw-r--r--debian/control1
-rw-r--r--debian/patches/paths.patch49
-rw-r--r--debian/patches/series2
7 files changed, 57 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index c83f4bf..c04fa3f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-chicago95 (0.0.2-1) obs; urgency=low
+chicago95 (2.0.1-1) obs; urgency=low
* New upstream release
* Remove distro name from version, because this package is now built for
@@ -6,7 +6,7 @@ chicago95 (0.0.2-1) obs; urgency=low
* Remove greeter theme (depended on obsolete webkit2-based greeter)
* Add chicago95-theme-sounds and chicago95-theme-plus
- -- B Stack <bgstack15@gmail.com> Mon, 29 Jun 2020 08:56:27 -0400
+ -- B Stack <bgstack15@gmail.com> Mon, 29 Jun 2020 15:03:44 -0400
chicago95 (0.0.1-1+devuan) obs; urgency=low
diff --git a/debian/chicago95-theme-doc.install b/debian/chicago95-theme-doc.install
index 78d10ff..31d13ad 100644
--- a/debian/chicago95-theme-doc.install
+++ b/debian/chicago95-theme-doc.install
@@ -1 +1 @@
-usr/share/doc/chicago95/*.md usr/share/doc/chicago95-theme-doc
+usr/share/doc/chicago95/* usr/share/doc/chicago95-theme-doc
diff --git a/debian/chicago95-theme-gtk.install b/debian/chicago95-theme-gtk.install
index c4413fa..1804693 100644
--- a/debian/chicago95-theme-gtk.install
+++ b/debian/chicago95-theme-gtk.install
@@ -1,2 +1,3 @@
/usr/share/xfce4/terminal/colorschemes/Chicago95.theme
/usr/share/themes/Chicago95
+/usr/share/xfce4-panel-profiles/layouts/Chicago95*
diff --git a/debian/chicago95-theme-plus.install b/debian/chicago95-theme-plus.install
index bd4e4ea..aa4419b 100644
--- a/debian/chicago95-theme-plus.install
+++ b/debian/chicago95-theme-plus.install
@@ -7,4 +7,6 @@
/usr/bin/ChicagoPlus
/usr/bin/PlusGUI
/usr/libexec/chicago95-theme-plus
+/usr/share/applications/PlusGUI.desktop
/usr/share/chicago95-theme-plus
+/usr/share/mime/packages/*.xml
diff --git a/debian/control b/debian/control
index 4472db0..0722650 100644
--- a/debian/control
+++ b/debian/control
@@ -54,6 +54,7 @@ Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends}, ${shlibs:Depends},
Suggests: qt5-style-plugins
+Breaks: chicago95-theme-greeter (<< ${binary:Version})
Description: GTK and WM themes for Chicago95
Themes for GTK2, GTK3, Metacity, and more, for the
Chicago95 theme suite.
diff --git a/debian/patches/paths.patch b/debian/patches/paths.patch
new file mode 100644
index 0000000..782c25c
--- /dev/null
+++ b/debian/patches/paths.patch
@@ -0,0 +1,49 @@
+Name: paths.patch
+Author: bgstack15@gmail.com
+Date: 2020-06-29 19:47
+Message: Use the system paths for the template themes.
+diff -x .git -x '.*.swp' -x '*.orig' -Naur Chicago95/Plus/ChicagoPlus.py Chicago95-dpkg/Plus/ChicagoPlus.py
+--- Chicago95/Plus/ChicagoPlus.py 2020-06-29 16:59:03.699020541 -0400
++++ Chicago95-dpkg/Plus/ChicagoPlus.py 2020-06-29 20:24:29.028121894 -0400
+@@ -1,6 +1,7 @@
+ #!/usr/bin/env python3
+
+ import sys
++sys.path.append("/usr/libexec/chicago95-theme-plus")
+ from pluslib import ChicagoPlus
+ import argparse
+ import logging
+diff -x .git -x '.*.swp' -x '*.orig' -Naur Chicago95/Plus/PlusGUI.py Chicago95-dpkg/Plus/PlusGUI.py
+--- Chicago95/Plus/PlusGUI.py 2020-06-29 16:58:06.138275601 -0400
++++ Chicago95-dpkg/Plus/PlusGUI.py 2020-06-29 20:25:05.264601994 -0400
+@@ -1,6 +1,7 @@
+ #!/usr/bin/env python3
+
+ import sys
++sys.path.append("/usr/libexec/chicago95-theme-plus")
+ from pluslib import ChicagoPlus
+ import logging
+ from pathlib import Path
+@@ -21,15 +22,15 @@
+ from gi.repository import Gtk, GdkPixbuf, GLib
+
+ running_folder = os.path.dirname(os.path.abspath(__file__))
+-share_dir = running_folder
+-libexec_dir = running_folder
+-work_dir = running_folder
++share_dir = "/usr/share/chicago95-theme-plus"
++libexec_dir = "/usr/libexec/chicago95-theme-plus"
++work_dir = os.path.expanduser("~")+"/tmp"
+ if not os.path.exists(work_dir):
+ os.makedirs(work_dir)
+
+-c95_packaged_cursor_path=str(Path.home())+"/.icons/Chicago95_Cursor_Black"
+-c95_packaged_theme_path=str(Path.home())+"/.themes/Chicago95"
+-c95_packaged_icons_path=str(Path.home())+"/.icons/Chicago95"
++c95_packaged_cursor_path="/usr/share/icons/Chicago95_Cursor_Black"
++c95_packaged_theme_path="/usr/share/themes/Chicago95"
++c95_packaged_icons_path="/usr/share/icons/Chicago95"
+
+ #print("Font List...", end=' ', flush=True)
+ fonts_output = subprocess.check_output(['convert', '-list', 'font'])
+
diff --git a/debian/patches/series b/debian/patches/series
index 4a97dfa..d851e26 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1 @@
-# You must remove unused comment lines for the released package.
+paths.patch
bgstack15