aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-07-15 20:44:34 -0400
committerB Stack <bgstack15@gmail.com>2020-07-15 20:44:34 -0400
commit3269b09c798e1db217748ddd89a0f2e2acfe8303 (patch)
tree91a9cb497d71353f6d5983e6a7cefaa520a9304a
parentadjust archive dir for obs (diff)
downloadchicago95-packages-3269b09c798e1db217748ddd89a0f2e2acfe8303.tar.gz
chicago95-packages-3269b09c798e1db217748ddd89a0f2e2acfe8303.tar.bz2
chicago95-packages-3269b09c798e1db217748ddd89a0f2e2acfe8303.zip
add paths.patch to rpm
-rw-r--r--chicago95.spec9
-rw-r--r--paths.patch49
2 files changed, 56 insertions, 2 deletions
diff --git a/chicago95.spec b/chicago95.spec
index b8fc5a7..ccc8200 100644
--- a/chicago95.spec
+++ b/chicago95.spec
@@ -11,6 +11,11 @@
%define archivename chicago95.orig.tar.gz
%define archivedir chicago95.orig
%endif
+# for OBS, Fedora 30, 31
+%if "0%{?_fontbasedir}" == "0"
+%define _fontbasedir %{_datadir}/fonts
+%endif
+
Name: chicago95-theme
Version: 2.0.1
Release: 1%{?dist}
@@ -20,11 +25,11 @@ Group: User Interface/Desktops
License: GPLv3.0+/MIT
URL: https://github.com/grassmunk/Chicago95
Source0: https://github.com/grassmunk/Chicago95/archive/%{archivename}
+Patch0: paths.patch
BuildArch: noarch
Packager: B Stack <bgstack15@gmail.com>
BuildRequires: txt2man
-#Provides: mimehandler(application/x-freefilesync-batch)
%description
Assets to allow customization of Xfce to look as
@@ -118,7 +123,7 @@ Translate Windows 95 Plus! themes to Gtk-compatible themes.
%prep
%setup -n %{archivedir}
-#%%patch0 -p1
+%patch0 -p1
%build
%make_build
diff --git a/paths.patch b/paths.patch
new file mode 100644
index 0000000..782c25c
--- /dev/null
+++ b/paths.patch
@@ -0,0 +1,49 @@
+Name: paths.patch
+Author: bgstack15@gmail.com
+Date: 2020-06-29 19:47
+Message: Use the system paths for the template themes.
+diff -x .git -x '.*.swp' -x '*.orig' -Naur Chicago95/Plus/ChicagoPlus.py Chicago95-dpkg/Plus/ChicagoPlus.py
+--- Chicago95/Plus/ChicagoPlus.py 2020-06-29 16:59:03.699020541 -0400
++++ Chicago95-dpkg/Plus/ChicagoPlus.py 2020-06-29 20:24:29.028121894 -0400
+@@ -1,6 +1,7 @@
+ #!/usr/bin/env python3
+
+ import sys
++sys.path.append("/usr/libexec/chicago95-theme-plus")
+ from pluslib import ChicagoPlus
+ import argparse
+ import logging
+diff -x .git -x '.*.swp' -x '*.orig' -Naur Chicago95/Plus/PlusGUI.py Chicago95-dpkg/Plus/PlusGUI.py
+--- Chicago95/Plus/PlusGUI.py 2020-06-29 16:58:06.138275601 -0400
++++ Chicago95-dpkg/Plus/PlusGUI.py 2020-06-29 20:25:05.264601994 -0400
+@@ -1,6 +1,7 @@
+ #!/usr/bin/env python3
+
+ import sys
++sys.path.append("/usr/libexec/chicago95-theme-plus")
+ from pluslib import ChicagoPlus
+ import logging
+ from pathlib import Path
+@@ -21,15 +22,15 @@
+ from gi.repository import Gtk, GdkPixbuf, GLib
+
+ running_folder = os.path.dirname(os.path.abspath(__file__))
+-share_dir = running_folder
+-libexec_dir = running_folder
+-work_dir = running_folder
++share_dir = "/usr/share/chicago95-theme-plus"
++libexec_dir = "/usr/libexec/chicago95-theme-plus"
++work_dir = os.path.expanduser("~")+"/tmp"
+ if not os.path.exists(work_dir):
+ os.makedirs(work_dir)
+
+-c95_packaged_cursor_path=str(Path.home())+"/.icons/Chicago95_Cursor_Black"
+-c95_packaged_theme_path=str(Path.home())+"/.themes/Chicago95"
+-c95_packaged_icons_path=str(Path.home())+"/.icons/Chicago95"
++c95_packaged_cursor_path="/usr/share/icons/Chicago95_Cursor_Black"
++c95_packaged_theme_path="/usr/share/themes/Chicago95"
++c95_packaged_icons_path="/usr/share/icons/Chicago95"
+
+ #print("Font List...", end=' ', flush=True)
+ fonts_output = subprocess.check_output(['convert', '-list', 'font'])
+
bgstack15