aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-07-14 21:42:28 -0400
committerB Stack <bgstack15@gmail.com>2020-07-14 21:42:28 -0400
commit14b0d86741941c6b805c979ac0da4d62af5f0624 (patch)
tree30ae3506b637f1198183d5f5624ea2e7e2a2834d
parentpackage -all depends on equal version (diff)
downloadchicago95-packages-14b0d86741941c6b805c979ac0da4d62af5f0624.tar.gz
chicago95-packages-14b0d86741941c6b805c979ac0da4d62af5f0624.tar.bz2
chicago95-packages-14b0d86741941c6b805c979ac0da4d62af5f0624.zip
WIP: first attempt at rpm spec
Builds all rpms but I have not tested any of them or listed contents.
-rw-r--r--chicago95.spec206
1 files changed, 206 insertions, 0 deletions
diff --git a/chicago95.spec b/chicago95.spec
new file mode 100644
index 0000000..5268127
--- /dev/null
+++ b/chicago95.spec
@@ -0,0 +1,206 @@
+%define debug_package %{nil}
+%define committish master
+Name: chicago95-theme
+Version: 2.0.1
+Release: 1%{?dist}
+Summary: XFCE Windows 95 Total Conversion
+
+Group: User Interface/Desktops
+License: GPLv3.0+/MIT
+URL: https://github.com/grassmunk/Chicago95
+Source0: https://github.com/grassmunk/Chicago95/archive/%{committish}.tar.gz
+
+BuildArch: noarch
+Packager: B Stack <bgstack15@gmail.com>
+BuildRequires: txt2man
+#Provides: mimehandler(application/x-freefilesync-batch)
+Requires: %{name}-backgrounds
+Requires: %{name}-cursors
+Requires: %{name}-doc
+Requires: %{name}-fonts
+Requires: %{name}-gtk
+Requires: %{name}-icons
+Requires: %{name}-login-sound
+Requires: %{name}-plus
+Requires: %{name}-plymouth
+Requires: %{name}-sounds
+
+%package backgrounds
+Summary: Backgrounds for Chicago95
+%description backgrounds
+Backgrounds that resemble some of the classic Windows 95
+wallpapers. This is part of the chicago95 theme suite.
+
+%package cursors
+Summary: Mouse cursor themes for Chicago95
+%description cursors
+Mouse cursors for the Chicago95 theme suite.
+
+%package doc
+Summary: Documentation for Chicago95
+%description doc
+Documentation and readmes for the Chicago95 theme
+suite, including ultimate ricing guides.
+
+%package fonts
+Summary: Fonts for Chicago95
+%description fonts
+Terminal fonts for the Chicago95 theme suite.
+Overall system fonts are proprietary but described
+in the documentation for the theme.
+
+%package gtk
+Recommends: qt5-qtstyleplugins
+Conflicts: %{name}-greeter < %{version}
+Summary: GTK and WM themes for Chicago95
+%description gtk
+Themes for GTK2, GTK3, Metacity, and more, for the
+Chicago95 theme suite.
+
+%package icons
+Summary: Icon themes for Chicago95
+%description icons
+Icon themes for Chicago95 theme suite.
+
+%package plymouth
+Requires: plymouth
+Summary: Plymouth theme for Chicago95
+%description plymouth
+Graphical theme for Plymouth bootloader, for the
+Chicago95 theme suite.
+
+%package sounds
+Summary: Sounds for Chicago95
+%description sounds
+UI sounds for Chicago95 theme.
+
+%package login-sound
+Requires: sox
+Summary: Login sound for Chicago95
+%description login-sound
+XDG autostart and sound file for Chicago95 theme suite.
+
+%package plus
+Requires: inkscape
+Requires: python3
+Requires: python3-fonttools
+Requires: python3-numpy
+Requires: python3-svgwrite
+Summary: Windows Plus! Theme Conversion for XFCE/Chicago95
+%description plus
+Translate Windows 95 Plus! themes to Gtk-compatible themes.
+
+%description
+Assets to allow customization of Xfce to look as
+close to Microsoft Windows 95 as possible. This
+metapackage depends on most of the other chicago95
+packages.
+
+%prep
+%setup -n Chicago95-%{committish}
+
+#%%patch0 -p1
+
+%build
+%make_build
+
+%install
+export use_underscores=YES
+%make_install
+
+%clean
+%{__rm} -rf %{buildroot} || :
+
+%post
+touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
+
+%preun
+# is it a final removal?
+#if test "$1" = "0" ;
+#then
+#fi
+
+%postun
+if test "$1" = "0" ;
+then
+ touch --no-create %{_datadir}/icons/hicolor &>/dev/null
+fi
+
+%posttrans plus
+update-desktop-database 1>/dev/null 2>&1 & :
+gtk-update-icon-cache %{_datadir}/icons/hicolor 1>/dev/null 2>&1 & :
+update-mime-database -n ${_datadir}/mime 1>/dev/null 2>&1 & :
+
+%files
+
+%files backgrounds
+%{_datadir}/backgrounds/Chicago95
+
+%files cursors
+%{_datadir}/icons/Chicago95_Cursor_Black/cursors
+%{_datadir}/icons/Chicago95_Cursor_Black/index.theme
+%{_datadir}/icons/Chicago95_Cursor_White/cursors
+%{_datadir}/icons/Chicago95_Cursor_White/index.theme
+%{_datadir}/icons/Chicago95_Emerald/cursors
+%{_datadir}/icons/Chicago95_Emerald/index.theme
+%{_datadir}/icons/Chicago95_Animated_Hourglass_Cursors/cursors
+%{_datadir}/icons/Chicago95_Animated_Hourglass_Cursors/index.theme
+%{_datadir}/icons/Chicago95_Standard_Cursors/cursors
+%{_datadir}/icons/Chicago95_Standard_Cursors/index.theme
+%{_datadir}/icons/Chicago95_Standard_Cursors_Black/cursors
+%{_datadir}/icons/Chicago95_Standard_Cursors_Black/index.theme
+
+%files doc
+%{_docdir}/chicago95
+
+%files fonts
+%{_fontbasedir}/truetype
+
+%files gtk
+%{_datadir}/xfce4/terminal/colorschemes/Chicago95.theme
+%{_datadir}/themes/Chicago95
+%{_datadir}/xfce4-panel-profiles/layouts/Chicago95*
+
+%files icons
+%{_datadir}/icons/Chicago95
+%{_datadir}/icons/Chicago95-tux
+
+%files login-sound
+%{_datadir}/sounds/Chicago95/startup.ogg
+%{_sysconfdir}/xdg/autostart/chicago95-startup.desktop
+
+%files plus
+%{_datadir}/icons/Chicago95_Cursor_Black/src
+%{_datadir}/icons/Chicago95_Cursor_White/src
+%{_datadir}/icons/Chicago95_Emerald/src
+%{_datadir}/icons/Chicago95_Animated_Hourglass_Cursors/build
+%{_datadir}/icons/Chicago95_Standard_Cursors/build
+%{_datadir}/icons/Chicago95_Standard_Cursors_Black/build
+%{_bindir}/ChicagoPlus
+%{_bindir}/PlusGUI
+%{_libexecdir}/chicago95-theme-plus
+%{_datadir}/applications/PlusGUI.desktop
+%{_datadir}/chicago95-theme-plus
+%{_datadir}/mime/packages/*.xml
+%{_mandir}/man1/ChicagoPlus.1.gz
+%{_mandir}/man1/PlusGUI.1.gz
+
+%files plymouth
+%{_datadir}/plymouth/themes
+
+%files sounds
+%{_datadir}/sounds/Chicago95/stereo
+%{_datadir}/sounds/Chicago95/index.theme
+#%license %attr(444, -, -) License.txt
+#%doc %attr(444, -, -) Changelog.txt
+#%{_bindir}/%{pkgname}
+#%{_bindir}/%{prog2name}
+#%{_datadir}/applications/*.desktop
+#%{_datadir}/icons/hicolor/*x*/*/*.png
+#%{_datadir}/mime/packages/*
+#%{_datadir}/%{name}
+#%%ghost %%config %%attr(666, -, -) %%{_datadir}/%%{name}/GlobalSettings.xml
+
+%changelog
+* Tue Jul 14 2020 B Stack <bgstack15@gmail.com> - 2.0.1-1
+- Initial rpm release
bgstack15