summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/window-valid.diff25
-rwxr-xr-xdebian/rules1
2 files changed, 26 insertions, 0 deletions
diff --git a/debian/patches/window-valid.diff b/debian/patches/window-valid.diff
new file mode 100644
index 00000000..6f6b0fd1
--- /dev/null
+++ b/debian/patches/window-valid.diff
@@ -0,0 +1,25 @@
+===================================================================
+RCS file: /cvs/gnome/zenity/src/util.c,v
+retrieving revision 1.14
+retrieving revision 1.15
+diff -u -r1.14 -r1.15
+--- util.c 2004/10/05 03:44:52 1.14
++++ util.c 2004/11/23 10:08:50 1.15
+@@ -272,8 +272,16 @@
+ if (wid_str) {
+ char *wid_str_end;
+ Window wid = strtoul (wid_str, &wid_str_end, 10);
+- if (*wid_str != '\0' && *wid_str_end == '\0' && wid != 0)
++ if (*wid_str != '\0' && *wid_str_end == '\0' && wid != 0) {
++ XWindowAttributes attrs;
++ gdk_error_trap_push ();
++ XGetWindowAttributes (GDK_DISPLAY(), wid, &attrs);
++ gdk_flush();
++ if (gdk_error_trap_pop () != 0) {
++ return None;
++ }
+ return wid;
++ }
+ }
+ return None;
+ }
diff --git a/debian/rules b/debian/rules
index efa9fe1c..492a9d61 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,7 @@
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
include /usr/share/gnome-pkg-tools/1/rules/uploaders.mk
clean::
bgstack15