summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index e7b30eb5..6a5f09ce 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,10 +3,14 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
+ifeq (,$(filter $(DEB_HOST_ARCH), ia64 kfreebsd-amd64 kfreebsd-i386 sh4))
+ ENABLE_WEBKIT = -Dwebkitgtk=true
+endif
+
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- \
- -Dlibnotify=true \
- -Dwebkitgtk=true
+ $(ENABLE_WEBKIT) \
+ -Dlibnotify=true
bgstack15