summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLogan Rathbone <poprocks@gmail.com>2021-06-28 23:17:46 -0400
committerLogan Rathbone <poprocks@gmail.com>2021-06-28 23:17:46 -0400
commit8d343b714fa4c0aeaa7e639892159aa0d619f124 (patch)
treeab094a0f74ebb52e60766a25c44784ee763aa912 /meson.build
parentmeson: disable libnotify and webkitgtk by default (diff)
downloadzenity-8d343b714fa4c0aeaa7e639892159aa0d619f124.tar.gz
zenity-8d343b714fa4c0aeaa7e639892159aa0d619f124.tar.bz2
zenity-8d343b714fa4c0aeaa7e639892159aa0d619f124.zip
meson: bump gtk req. Suppress compiler warning.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f65475a0..20ce5082 100644
--- a/meson.build
+++ b/meson.build
@@ -49,7 +49,11 @@ foreach h : check_headers
cc.has_header(h, required: true)
endforeach
-gtk_dep = dependency('gtk+-3.0', version: '>= 3.0.0')
+gtk_dep = dependency('gtk+-3.0', version: '>= 3.16.0')
+
+# this is the minimum required glib according to the above-mentioned version of gtk
+# it's really just being documented here for ease of reference.
+glib_dep = dependency('glib-2.0', version: '>= 2.43.4')
# Optional dependencies
bgstack15