summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <pochu@debian.org>2010-02-27 14:41:57 +0000
committerEmilio Pozuelo Monfort <pochu@debian.org>2010-02-27 14:41:57 +0000
commit8a1a2ef0857c8afd7076e176693bb5757e63f11c (patch)
treebb2bb5644a9f86faced624b1eb0646001a257c64 /debian
parent* debian/control.in: (diff)
downloadzenity-8a1a2ef0857c8afd7076e176693bb5757e63f11c.tar.gz
zenity-8a1a2ef0857c8afd7076e176693bb5757e63f11c.tar.bz2
zenity-8a1a2ef0857c8afd7076e176693bb5757e63f11c.zip
* debian/patches/02_dont_quit_zenity_when_stdin_ends.patch:
- Don't quit zenity when listening on stdin and the stream ends. Closes: #506425.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/02_dont_quit_zenity_when_stdin_ends.patch30
2 files changed, 36 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 9f773d9d..aa87e094 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,14 @@
zenity (2.28.0-2) UNRELEASED; urgency=low
+ [ Andrea Veri ]
* debian/control.in:
- really don't B-D on scrollkeeper anymore.
+ [ Emilio Pozuelo Monfort ]
+ * debian/patches/02_dont_quit_zenity_when_stdin_ends.patch:
+ - Don't quit zenity when listening on stdin and the stream ends.
+ Closes: #506425.
+
-- Andrea Veri <andrea.veri89@gmail.com> Fri, 06 Nov 2009 00:20:01 +0100
zenity (2.28.0-1) unstable; urgency=low
diff --git a/debian/patches/02_dont_quit_zenity_when_stdin_ends.patch b/debian/patches/02_dont_quit_zenity_when_stdin_ends.patch
new file mode 100644
index 00000000..3310189a
--- /dev/null
+++ b/debian/patches/02_dont_quit_zenity_when_stdin_ends.patch
@@ -0,0 +1,30 @@
+From fc381b5938f7235401286d4821f03d2b05d4876a Mon Sep 17 00:00:00 2001
+From: Emilio Pozuelo Monfort <pochu27@gmail.com>
+Date: Sat, 27 Feb 2010 15:32:23 +0100
+Subject: [PATCH] Don't quit zenity when the input stream is closed
+
+When using --listen for a notification, zenity quits when the stream
+ends. This makes it impossible to read commands from a pipe as in
+`echo icon:info | zenity --notification --listen'.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=525596
+---
+ src/notification.c | 2 --
+ 1 files changed, 0 insertions(+), 2 deletions(-)
+
+diff --git a/src/notification.c b/src/notification.c
+index 674eaec..ab44477 100644
+--- a/src/notification.c
++++ b/src/notification.c
+@@ -229,8 +229,6 @@ zenity_notification_handle_stdin (GIOChannel *channel,
+
+ if ((condition & G_IO_HUP) != 0) {
+ g_io_channel_shutdown (channel, TRUE, NULL);
+- zen_data->exit_code = zenity_util_return_exit_code (ZENITY_OK);
+- gtk_main_quit ();
+ return FALSE;
+ }
+
+--
+1.7.0
+
bgstack15