summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2023-06-19 14:52:41 +0100
committerSimon McVittie <smcv@debian.org>2023-06-19 14:52:41 +0100
commit945fb90b2724c4d23730b9a65dc4327eaaf39df7 (patch)
tree3e97343581674eba247b57bf84d900ef8a50f910 /debian/rules
parentreleasing package zenity version 3.44.0-1 (diff)
downloadzenity-945fb90b2724c4d23730b9a65dc4327eaaf39df7.tar.gz
zenity-945fb90b2724c4d23730b9a65dc4327eaaf39df7.tar.bz2
zenity-945fb90b2724c4d23730b9a65dc4327eaaf39df7.zip
Disable WebKit integration (--html option)
This adds several "heavy" dependencies, notably WebKit itself, but also video and spellchecking among others, which are undesired for a simple interactive dialog. The WebKit feature is disabled by default upstream, and several major distributions (including at least the Fedora/Red Hat family, Arch and openSUSE) don't enable it in their packaging, so portable software cannot rely on this option being available. According to codesearch.debian.net, none of the packages with a dependency on zenity use the --html option. The beginning of the Debian 13 cycle seems is a good time to make this sort of potentially disruptive change; most likely nobody will notice this feature going away, but if we get bug reports, we can consider other options such as having a zenity-minimal package without HTML support, or having a zenity-full package with it. Closes: #777608, #942362
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 3 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 9f4dfd23..00f22caa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,14 +3,11 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
-ifeq (,$(filter $(DEB_HOST_ARCH), hurd-i386 ia64 kfreebsd-amd64 kfreebsd-i386 sh4))
- ENABLE_WEBKIT = -Dwebkitgtk=true
-endif
-
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- \
- $(ENABLE_WEBKIT) \
- -Dlibnotify=true
+ -Dlibnotify=true \
+ -Dwebkitgtk=false \
+ ${NULL}
bgstack15