summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2019-04-03 22:56:05 +0200
committerSebastien Bacher <seb128@ubuntu.com>2019-04-03 22:56:05 +0200
commitadf17243a6b6d0cac2d7302b4443ac0bceb8575d (patch)
treee619c7f2e7ce628e9950ae3e1451fcde8e210cc3 /configure.ac
parentNew upstream version 3.30.0 (diff)
parentBump to 3.32.0 (diff)
downloadzenity-adf17243a6b6d0cac2d7302b4443ac0bceb8575d.tar.gz
zenity-adf17243a6b6d0cac2d7302b4443ac0bceb8575d.tar.bz2
zenity-adf17243a6b6d0cac2d7302b4443ac0bceb8575d.zip
New upstream version 3.32.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 63ca67a3..5dccdb07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
-AC_INIT([Zenity],[3.30.0],[https://bugzilla.gnome.org/enter_bug.cgi?product=zenity],[zenity])
+AC_INIT([Zenity],[3.32.0],[https://bugzilla.gnome.org/enter_bug.cgi?product=zenity],[zenity])
-AC_PREREQ([2.63])
+AC_PREREQ([2.69])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR([src])
@@ -11,6 +11,12 @@ AM_MAINTAINER_MODE([enable])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+# *******************************
+# Debug
+# *******************************
+
+AX_CHECK_ENABLE_DEBUG([yes],[GNOME_ENABLE_DEBUG])
+
# Check for programs
AC_PROG_CC
@@ -27,7 +33,7 @@ dnl *************************
zenity_save_cflags="$CFLAGS"
# pull in the CFLAGS to locate gdkconfig.h
CFLAGS=`$PKG_CONFIG --cflags gtk+-3.0`
-AC_COMPILE_IFELSE([
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <gdk/gdk.h>
int main(void) {
@@ -36,7 +42,7 @@ int main(void) {
#endif
return 0;
}
-],
+])],
GDK_BACKEND_X11=yes,
GDK_BACKEND_X11=no)
@@ -98,12 +104,6 @@ if test x$enable_webkitgtk = xyes; then
fi
fi
-# *******************************
-# Debug
-# *******************************
-
-GNOME_DEBUG_CHECK
-GNOME_COMPILE_WARNINGS([maximum])
# *******************************
# Internationalization
bgstack15