summaryrefslogtreecommitdiff
path: root/yt-dlp/debian/patches/0004-Skip-directories-and-style-checks-for-flake8.patch
diff options
context:
space:
mode:
Diffstat (limited to 'yt-dlp/debian/patches/0004-Skip-directories-and-style-checks-for-flake8.patch')
-rw-r--r--yt-dlp/debian/patches/0004-Skip-directories-and-style-checks-for-flake8.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/yt-dlp/debian/patches/0004-Skip-directories-and-style-checks-for-flake8.patch b/yt-dlp/debian/patches/0004-Skip-directories-and-style-checks-for-flake8.patch
new file mode 100644
index 0000000..a51bd78
--- /dev/null
+++ b/yt-dlp/debian/patches/0004-Skip-directories-and-style-checks-for-flake8.patch
@@ -0,0 +1,24 @@
+From: =?utf-8?q?Rog=C3=A9rio_Theodoro_de_Brito?= <rbrito@gmail.com>
+Date: Sun, 22 Nov 2020 20:05:27 -0300
+Subject: Skip directories and style checks for flake8
+
+Forwarded: no
+Last-Update: 2020-04-10
+---
+ Makefile | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+--- a/Makefile 2021-12-01 15:12:30.374957372 -0500
++++ b/Makefile 2021-12-01 15:12:30.362957495 -0500
+@@ -49,7 +49,10 @@
+ install -Dm644 completions/fish/yt-dlp.fish $(DESTDIR)$(SHAREDIR)/fish/vendor_completions.d/yt-dlp.fish
+
+ codetest:
+- flake8 .
++ flake8 \
++ --exclude=.svn,CVS,.bzr,.hg,.git,__pycache__,.tox,.eggs,*.egg,.pc,.pybuild \
++ --ignore=E121,E123,E126,E226,E24,E704,E402,E501,E731,E741,W503,W504,N802,N803,N806,N816,F401,F821,E302,E305,N801,N815,E265,N813,F403,F405 \
++ .
+
+ test:
+ $(PYTHON) -m pytest
bgstack15