summaryrefslogtreecommitdiff
path: root/xseticon/debian/patches/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'xseticon/debian/patches/Makefile.patch')
-rw-r--r--xseticon/debian/patches/Makefile.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/xseticon/debian/patches/Makefile.patch b/xseticon/debian/patches/Makefile.patch
new file mode 100644
index 0000000..b5b4279
--- /dev/null
+++ b/xseticon/debian/patches/Makefile.patch
@@ -0,0 +1,17 @@
+Date: 2020-02-10
+Author: bgstack15
+Notes: The order of flags matters to gcc on Devuan. Fedora did not need this the same way.
+References:
+Web search "undefined reference to `XAllowEvents"
+https://github.com/aktau/hhpc/commit/1c97ac2c69abf475af9746e0dc31170e0ee9b00b
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@ xseticon.o: xseticon.c
+ gcc ${GLIB_CFLAGS} ${XLIB_CFLAGS} -c $^ -o $@
+
+ xseticon: xseticon.o
+- gcc ${LIBS} $^ -o $@
++ gcc $^ -o $@ ${LIBS}
+
+ .PHONY: clean
+ clean:
bgstack15