summaryrefslogtreecommitdiff
path: root/xdgmenumaker/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'xdgmenumaker/debian/rules')
-rwxr-xr-xxdgmenumaker/debian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/xdgmenumaker/debian/rules b/xdgmenumaker/debian/rules
new file mode 100755
index 0000000..8904aab
--- /dev/null
+++ b/xdgmenumaker/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ dh_auto_install -- PREFIX=/usr
+
+#override_dh_install:
+# dh_install --list-missing -X.pyc -X.pyo
+
+# Not working, but a good idea. Reference: https://phabricator.wikimedia.org/D463
+#override_dh_auto_python:
+# dh_python3 --shebang=/usr/bin/python3
+
+override_dh_auto_test:
+ echo skip tests because output depends on locally-installed icon files existing
bgstack15